add models, vusolo/vuuno/vuultimo/vusolo2/vuduo2
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-core / initscripts / initscripts_1.0.bbappend
1 PR .= "-vuplus1"
2
3 #BOOTUP = "${@base_contains('PREFERRED_VERSION_linux-vuplus', '3.1.1', 'bootup_3.1', ' ', d)}"
4 #BOOTUP_vusolo2 = "${@base_contains('PREFERRED_VERSION_linux-vuplus', '3.3.6', 'bootup_3.1', ' ', d)}"
5 BOOTUP = "bootup_3.1" 
6
7 SRC_URI_append = " \
8         file://turnoff_power \
9         file://hotplug_br \
10         file://make_mac_sector \
11         file://${BOOTUP} \
12 "
13
14 do_install_append() {
15         rm ${D}${sysconfdir}/*.d/*save-rtc.sh
16
17         install -d ${D}/usr/bin 
18         install -m 0755 ${WORKDIR}/turnoff_power     ${D}/usr/bin
19         install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
20         install -m 0755 ${WORKDIR}/make_mac_sector   ${D}/usr/bin
21         install -m 0755 ${WORKDIR}/${BOOTUP}         ${D}${sysconfdir}/init.d/bootup
22         ln      -sf     ../init.d/bootup             ${D}${sysconfdir}/rcS.d/S05bootup
23 }
24
25 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
26
27 PACKAGE_ARCH = "${MACHINE_ARCH}"