[wvstreams] build fix
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / wvstream / wvstreams_4.6.bb
1 HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6 DESCRIPTION = "WvStreams is a network programming library in C++"
7 DEPENDS = "zlib openssl (>= 0.9.8)"
8
9 SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
10         file://vuplus-wvstreams-build-fix.patch \
11         file://vuplus-wvstreams-build-fix_getuid.patch \
12         "
13
14 inherit autotools pkgconfig
15
16 LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
17 EXTRA_OECONF = " --without-tcl --without-qt --without-pam "
18
19 PARALLEL_MAKE = ""
20
21 do_configure() {
22         autoreconf
23         oe_runconf
24 }
25
26 do_install() {
27         oe_runmake DESTDIR=${D} install
28 }
29
30 #FILES_${PN} = "/"
31 FILES__${PN} = ""
32 FILES__${PN} += "${libdir}/libuniconf.so.*"
33 FILES__${PN} += "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
34 FILES__${PN} += "${libdir}/libwvutils.so.*"
35 FILES__${PN} += "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
36
37
38 SRC_URI[md5sum] = "4ee8ccfe6dfc29bf952d58fa23626c97"
39 SRC_URI[sha256sum] = "171df8e545b53edb3efbd65b9bc2b35549d05249bd0c92776701f9d8da77ed6f"
40