Merge remote-tracking branch 'OE-2.1/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / wvstream / wvstreams_4.6.bb
1 HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6 DESCRIPTION = "WvStreams is a network programming library in C++"
7 DEPENDS = "zlib openssl (>= 0.9.8) dbus (>  1.2.14)"
8
9 PR = "r1"
10
11 SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
12         file://vuplus-wvstreams-build-fix.patch \
13         file://vuplus-wvstreams-build-fix_getuid.patch \
14         "
15
16 inherit autotools-brokensep pkgconfig
17
18 LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
19 EXTRA_OECONF = " --without-tcl --without-qt --without-pam "
20
21 PARALLEL_MAKE = ""
22
23 do_configure() {
24         autoreconf
25         oe_runconf
26 }
27
28 do_install() {
29         oe_runmake DESTDIR=${D} install
30 }
31
32 #FILES_${PN} = "/"
33 FILES__${PN} = ""
34 FILES__${PN} += "${libdir}/libuniconf.so.*"
35 FILES__${PN} += "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
36 FILES__${PN} += "${libdir}/libwvutils.so.*"
37 FILES__${PN} += "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
38
39
40 SRC_URI[md5sum] = "4ee8ccfe6dfc29bf952d58fa23626c97"
41 SRC_URI[sha256sum] = "171df8e545b53edb3efbd65b9bc2b35549d05249bd0c92776701f9d8da77ed6f"
42