01afd5d8606faee936d8a021a4583f745edd2fb7
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / wvstream / wvstreams_4.6.bb
1 HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6 DESCRIPTION = "WvStreams is a network programming library in C++"
7 DEPENDS = "zlib openssl (>= 0.9.8)"
8
9 SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
10         file://vuplus-wvstreams-build-fix.patch;patch=1;pnum=1 \
11         "
12
13 inherit autotools pkgconfig
14
15 LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
16 EXTRA_OECONF = " --without-tcl --without-qt --without-pam "
17
18 PARALLEL_MAKE = ""
19
20 do_configure() {
21         autoreconf
22         oe_runconf
23 }
24
25 do_install() {
26         oe_runmake DESTDIR=${D} install
27 }
28
29 #FILES_${PN} = "/"
30 FILES__${PN} = ""
31 FILES__${PN} += "${libdir}/libuniconf.so.*"
32 FILES__${PN} += "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
33 FILES__${PN} += "${libdir}/libwvutils.so.*"
34 FILES__${PN} += "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
35
36
37 SRC_URI[md5sum] = "4ee8ccfe6dfc29bf952d58fa23626c97"
38 SRC_URI[sha256sum] = "171df8e545b53edb3efbd65b9bc2b35549d05249bd0c92776701f9d8da77ed6f"
39