update proxy drivers and utils
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / wvdial / wvdial_1.60.bb
1 HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
2 DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
3
4 PR = "r4"
5
6 LICENSE = "GPLv2"
7 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
8
9 SRC_URI = "\
10         http://www.alumnit.ca/download/wvdial-1.60.tar.gz \
11         file://wvdial-vuplus_001.patch;patch=1 \
12         "
13
14 DEPENDS = "wvstreams ppp"
15 RDEPENDS_${PN} = "ppp wvstreams"
16
17 inherit autotools pkgconfig
18
19 CFLAGS += " -Wno-write-strings "
20 LDFLAGS = " -L ${CROSS_DIR}/${TARGET_SYS}/usr/lib -luniconf -lwvstreams -lwvbase -lwvutils "
21
22 EXTRA_OEMAKE = ""
23 export CC="${CXX}"
24
25 do_compile() {
26         oe_runmake
27 }
28
29 do_install() {
30     install -d ${D}/etc/ppp/peers
31     oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
32 }
33
34 SRC_URI[md5sum] = "27fbbde89f8fd9f6e735a8efa5217fc9"
35 SRC_URI[sha256sum] = "0c65ea807950fab32e659d1869a7167ff978502bd5d0159dbe9de90eb6c2e16b"
36