update drivers(duo2, solo2, solose, zero)
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / realtek / r8192cu_4.0.2.9000.20130911.bb
1 SUMMARY = "Driver for Realtek USB wireless devices"
2 HOMEPAGE = "http://www.realtek.com/"
3 LICENSE = "GPLv2"
4 PR = "r1"
5 LIC_FILES_CHKSUM = "file://os_dep/linux/os_intfs.c;endline=19;md5=72c75de415f1e8a42587d170459677e2"
6
7 SRC_URI = " \
8         file://rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911.tar.gz \
9         file://r8192cu_remove_debug.patch \
10 "
11
12 S = "${WORKDIR}/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911"
13
14 inherit module siteinfo
15
16 EXTRA_OEMAKE = "CONFIG_RTL8192CU=m"
17
18 do_configure() {
19         sed -e "s/^CONFIG_PLATFORM_I386_PC.*=.*y/EXTRA_CFLAGS += -DCONFIG_${@base_conditional('SITEINFO_ENDIANNESS', 'le', 'LITTLE', 'BIG', d)}_ENDIAN/" -i Makefile
20 }
21 do_compile() {
22         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
23         oe_runmake -C "${STAGING_KERNEL_DIR}" M="${S}" modules 
24 }
25
26 do_install() {
27         install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
28         install -m 0644 ${S}/8192cu.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
29 }
30