[libpng] downgrade to 1.6.8 for prevent warning message.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / packagegroups / packagegroup-vuplus-wlan.bb
1 DESCRIPTION = "Vuplus: W-LAN package group for the Vuplus Distribution"
2 SECTION = "vuplus/base"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5 PR = "r15"
6
7 inherit packagegroup
8
9 DEPENDS_${PN} = "enigma2"
10 RDEPENDS_${PN} = "\
11         enigma2-plugin-systemplugins-wirelesslansetup \
12         wireless-tools \
13         wpa-supplicant \
14 "
15
16 WIFI_FIRMWARES = "\
17         rt73-firmware \
18         zd1211-firmware \
19         firmware-htc9271 \
20         firmware-rt2561 \
21         firmware-rtl8721u \
22         firmware-rt3070 \
23 "
24
25 KERNEL_WIFI_MODULES = " \
26         kernel-module-ath9k-htc \
27         kernel-module-carl9170 \
28         kernel-module-prism2-usb \
29         kernel-module-rt73usb \
30         kernel-module-rt2500usb \
31         kernel-module-rtl8187 \
32         kernel-module-r8712u \
33         kernel-module-w35und \
34         kernel-module-zd1211rw \
35         kernel-module-llc \
36         kernel-module-stp \
37         kernel-module-bridge \
38         kernel-module-hostap \
39         ${@base_contains('VUPLUS_FEATURES', 'ralink-kmod', 'kernel-module-rt2800usb', ' ', d)} \
40 "
41
42 KERNEL_WIFI_MODULES += "${@base_version_less_or_equal('VUPLUS_KERNEL_VERSION', '3.1.1', 'kernel-module-r8192u-usb', '', d)}"
43
44 LEGACY_MODULES = " \
45         ${@base_contains('VUPLUS_FEATURES', 'ralink-legacy', 'rt3070', ' ', d)} \
46         r8192cu \
47 "
48
49 RDEPENDS_${PN}_append = "\
50         ${WIFI_FIRMWARES} \
51         ${KERNEL_WIFI_MODULES} \
52         ${LEGACY_MODULES} \
53         rt2870sta \
54 "
55
56 PACKAGE_ARCH = "${MACHINE_ARCH}"
57