openssl: backport c09bf5d177a7ecd2045ef7e13fff4528137a9775 from OE-Core
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / openssl / openssl_0.9.8x.bb
1 require recipes-connectivity/openssl/openssl.inc
2
3 PR = "${INC_PR}.1"
4
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
6
7 SRC_URI += "file://debian/ca.patch \
8             file://debian/config-hurd.patch;apply=no \
9             file://debian/debian-targets.patch \
10             file://debian/engines-path.patch \
11             file://debian/kfreebsd-pipe.patch;apply=no \
12             file://debian/make-targets.patch \
13             file://debian/man-dir.patch \
14             file://debian/man-section.patch \
15             file://debian/no-rpath.patch \
16             file://debian/no-symbolic.patch \
17             file://debian/pic.patch \
18             file://debian/pkg-config.patch \
19             file://debian/rc4-amd64.patch \
20             file://debian/rehash-crt.patch \
21             file://debian/rehash_pod.patch \
22             file://debian/shared-lib-ext.patch \
23             file://debian/stddef.patch \
24             file://debian/version-script.patch \
25             file://debian/perl-path.diff"
26
27 SRC_URI += "file://configure-targets.patch \
28             file://shared-libs.patch \
29             file://parallel-make-fix.patch \
30             file://find.pl"
31
32 SRC_URI[md5sum] = "ee17e9bc805c8cc7d0afac3b0ef78eda"
33 SRC_URI[sha256sum] = "7ce0c7f2c451070b4497ea7ca6f23eba6cef1a56db2e86e433f65926a7bc7497"
34
35 EXTRA_OECONF += "no-idea no-mdc2 no-rc5"
36
37 do_configure_prepend() {
38         cp ${WORKDIR}/find.pl ${S}/util/find.pl
39 }
40
41 BBCLASSEXTEND = "native nativesdk"
42
43 PARALLEL_MAKEINST = ""