Merge remote-tracking branch 'oe_21/master' into vuplus-3.0-next
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / libmicrohttpd / libmicrohttpd_0.4.6.bb
1 DESCRIPTION = "GNU libmicrohttpd is a small C library that is supposed to make it easy to run an HTTP server as part of another application."
2 LICENSE = "LGPLv2.1"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
4
5 DEPENDS = "libgcrypt curl"
6
7 SRC_URI = "ftp://ftp.nluug.nl/pub/gnu/libmicrohttpd//libmicrohttpd-${PV}.tar.gz"
8 SRC_URI[md5sum] = "61698da6aa04744ea076c327f66fc05a"
9 SRC_URI[sha256sum] = "0cb09e26678d1531a4fd40a748abff5142bfdad3ae11cfe3bb7ad7317a99e371"
10
11 inherit autotools lib_package
12
13 do_compile_append() {
14         sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
15 }