[autofs] build fix
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-connectivity / autofs / autofs_4.1.4.bb
1 SUMMARY = "kernel-based automounter for Linux"
2 SECTION = "base"
3 LICENSE = "GPLv2+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 PR = "r10"
6
7 SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v4/${BP}.tar.bz2 \
8            file://020_auto_net_path_sortlocale_mountoptions.patch \
9            file://037_let_debian_rules_decide_on_CFLAGS.patch \
10            file://042_default_auto_master_all_commented_out.patch \
11            file://060_non_replicated_ping.patch \
12            file://061_multi_parse_fix.patch \
13            file://062_fix_memory_leak.patch \
14            file://063_misc_fixes.patch \
15            file://064_support_options_on_nis_maps.patch \
16            file://065_fix_master_map_in_ldap.patch \
17            file://066_canonicalise_mount_points.patch \
18            file://067_allow_disabling_bind_mounts.patch \
19            file://067_ldap_no_first_message.patch \
20            file://068_fix_invalid_rpcgen_code.patch \
21            file://069_support_spaces_in_smb_share_names.patch \
22            file://070_fix_regex_typo.patch \
23            file://071_fix_ldap_mounts.patch \
24            file://072_fix_auto_net_sort.patch \
25            file://073_configurable_locking.patch \
26            file://074_auto_smb_cifs.patch \
27            file://075_auto_net_escape_hash.patch \
28            file://076_ldap_deprecated.patch \
29            file://078_locking_fix_1.patch \
30            file://079_no_unlink_upstream.patch \
31            file://080_auto_smb_probe_credentials.patch \
32            file://081_auto_net_showmount_quotes.patch \
33            file://082_samples_makefile_typo.patch \
34            file://083_clarify_program_map_outputsyntax.patch \
35            file://084_init_lsb_header.patch \
36            file://085_auto_net_lp111612.patch \
37            file://cross.patch \
38            file://Makefile.rules-cross.patch \
39            file://install.patch \
40            file://no-bash.patch \
41            file://auto.hotplug \
42            file://auto.master \
43            file://auto.network \
44            file://autofs.default \
45            file://autofs.init \
46            file://volatiles.99_autofs \
47 "
48 SRC_URI[md5sum] = "7e3949114c00665b4636f0c318179657"
49 SRC_URI[sha256sum] = "e25caa0e9639ea54dd7c4f21e8146ac9859a61fa126f397edf874b5fdc147430"
50
51 S = "${WORKDIR}/${BP}"
52
53 inherit autotools-brokensep update-rc.d
54
55 do_configure_prepend () {
56         if [ ! -e acinclude.m4 ]; then
57                 cp aclocal.m4 acinclude.m4
58         fi
59 }
60 do_install () {
61         oe_runmake 'INSTALLROOT=${D}' install
62         install -d ${D}${sysconfdir}/default
63         install -m 644 ${WORKDIR}/autofs.default ${D}${sysconfdir}/default/autofs
64         install -d ${D}${sysconfdir}/init.d
65         install -m 755 ${WORKDIR}/autofs.init ${D}${sysconfdir}/init.d/autofs
66         install -m 644 ${WORKDIR}/auto.hotplug ${D}${sysconfdir}/auto.hotplug
67         install -m 644 ${WORKDIR}/auto.master ${D}${sysconfdir}/auto.master
68         install -m 644 ${WORKDIR}/auto.network ${D}${sysconfdir}/auto.network
69         install -d ${D}${sysconfdir}/default/volatiles
70         install -m 644 ${WORKDIR}/volatiles.99_autofs ${D}${sysconfdir}/default/volatiles/99_autofs
71 }
72
73 RDEPENDS_${PN} = "procps"
74
75 INITSCRIPT_NAME = "autofs"
76 INITSCRIPT_PARAMS = "defaults"
77
78 PARALLEL_MAKE = ""
79
80 INSANE_SKIP_${PN} = "dev-so"