[satipclient] fix vtuner defines at kver >= 3.14
[vuplus_openvuplus_3.0] / meta-openvuplus / classes / distutils-openplugins.bbclass
1 inherit distutils
2
3 # Scripts want to install "/etc", so we need "--root" instead of setting install-data stuff
4 # to remain compatible with previous versions.
5
6 DISTUTILS_INSTALL_ARGS = "\
7     --root=${D} \
8     --install-data=${datadir} \
9     --install-lib=${libdir}/enigma2/python/Plugins \
10     "
11
12 # Remove "egg-info" files. If datadir or site-packages dir is empty, remove it.
13 distutils_do_install_append() {
14         rm -f ${D}${libdir}/enigma2/python/Plugins/*.egg-info
15         rmdir -p --ignore-fail-on-non-empty ${D}${datadir} ${D}/${PYTHON_SITEPACKAGES_DIR} || true
16 }