[dvbapp] fix MIS/PLS & support blindscan for zero4k.
[vuplus_openvuplus_3.0] / meta-bsp / recipes-vuplus / enigma2 / enigma2.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 PR .= "-bsp25"
4
5 SRC_URI_append_vusolo = " \
6         file://enigma2_vuplus_misc.patch \
7 "
8
9 SRC_URI_append_vuultimo = " \
10         file://analog.ttf \
11         file://skin_user.xml \
12         file://vfd_icons \
13 "
14
15 SRC_URI_append_vuduo2 = " \
16         file://skin_user_vuduo2.xml \
17         file://vfd_icons_vuduo2 \
18 "
19
20 SRC_URI_append_vusolose = " \
21         file://enigma2_vuplus_remove_pvr_action.patch \
22 "
23
24 SRC_URI_append_vuzero = " \
25         file://enigma2_vuplus_remove_pvr_action.patch \
26 "
27
28 SRC_URI_append_vusolo4k = " \
29         file://skin_user_vusolo4k.xml \
30         file://lcd_icons_vusolo4k \
31         file://vu_hd_1080p_default.patch \
32         file://enigma2_vuplus_check_recording.patch \
33 "
34
35 SRC_URI_append_vuultimo4k = " \
36         file://skin_user_vuultimo4k.xml \
37         file://lcd_icons_vuultimo4k \
38         file://vu_hd_1080p_default.patch \
39         file://enigma2_network_sys0.patch \
40 "
41
42 SRC_URI_append_vuuno4k = " \
43         file://enigma2_vuplus_remove_pvr_action.patch \
44         file://vu_hd_1080p_default.patch \
45         file://enigma2_vuplus_uianimation_speed.patch \
46 "
47
48 SRC_URI_append_vuuno4kse = " \
49         file://skin_user_vuuno4kse.xml \
50         file://lcd_icons_vuuno4kse \
51         file://vu_hd_1080p_default.patch \
52         file://enigma2_vuplus_uianimation_speed.patch \
53         file://enigma2_vuplus_check_recording.patch \
54 "
55
56 SRC_URI_append_vuzero4k = " \
57         file://vu_hd_1080p_default.patch \
58         file://enigma2_vuplus_uianimation_speed.patch \
59         file://enigma2_vuplus_check_recording.patch \
60         file://enigma2_vuplus_zero4k_hdd_recording.patch \
61         file://enigma2_vuplus_dvbs2x.patch \
62         file://enigma2_vuplus_mis_pls.patch \
63         file://enigma2_vuplus_zero4k_blindscan.patch \
64 "
65
66 do_install_append_vuultimo() {
67         install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
68         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
69         install -d ${D}/usr/share/enigma2/vfd_icons/
70         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
71 }
72
73 do_install_append_vuduo2() {
74         install -m 0755 ${WORKDIR}/skin_user_vuduo2.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
75         install -d ${D}/usr/share/enigma2/vfd_icons/
76         install -m 0755 ${WORKDIR}/vfd_icons_vuduo2/*.png ${D}/usr/share/enigma2/vfd_icons/
77 }
78
79 do_install_append_vusolo4k() {
80         install -m 0755 ${WORKDIR}/skin_user_vusolo4k.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
81         install -d ${D}/usr/share/enigma2/lcd_icons/
82         install -m 0755 ${WORKDIR}/lcd_icons_vusolo4k/*.png ${D}/usr/share/enigma2/lcd_icons/
83 }
84
85 do_install_append_vuultimo4k() {
86         install -m 0755 ${WORKDIR}/skin_user_vuultimo4k.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
87         install -d ${D}/usr/share/enigma2/lcd_icons/
88         install -m 0755 ${WORKDIR}/lcd_icons_vuultimo4k/*.png ${D}/usr/share/enigma2/lcd_icons/
89 }
90
91 do_install_append_vuuno4kse() {
92         install -m 0755 ${WORKDIR}/skin_user_vuuno4kse.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
93         install -d ${D}/usr/share/enigma2/lcd_icons/
94         install -m 0755 ${WORKDIR}/lcd_icons_vuuno4kse/*.png ${D}/usr/share/enigma2/lcd_icons/
95 }
96