Solo4K Support.
[vuplus_openvuplus_3.0] / meta-bsp / recipes-vuplus / enigma2 / enigma2.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 PR .= "-bsp5"
4
5 SRC_URI_append_vusolo = " \
6         file://enigma2_vuplus_misc.patch \
7 "
8
9 SRC_URI_append_vuultimo = " \
10         file://analog.ttf \
11         file://skin_user.xml \
12         file://vfd_icons \
13 "
14
15 SRC_URI_append_vuduo2 = " \
16         file://skin_user_vuduo2.xml \
17         file://vfd_icons_vuduo2 \
18 "
19
20 SRC_URI_append_vusolose = " \
21         file://enigma2_vuplus_remove_pvr_action.patch \
22 "
23
24 SRC_URI_append_vuzero = " \
25         file://enigma2_vuplus_remove_pvr_action.patch \
26 "
27
28 SRC_URI_append_vusolo4k = " \
29         file://skin_user_vusolo4k.xml \
30         file://lcd_icons_vusolo4k \
31         file://enigma2_dvb_ci_fbc.patch \
32 "
33
34 do_install_append_vuultimo() {
35         install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
36         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
37         install -d ${D}/usr/share/enigma2/vfd_icons/
38         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
39 }
40
41 do_install_append_vuduo2() {
42         install -m 0755 ${WORKDIR}/skin_user_vuduo2.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
43         install -d ${D}/usr/share/enigma2/vfd_icons/
44         install -m 0755 ${WORKDIR}/vfd_icons_vuduo2/*.png ${D}/usr/share/enigma2/vfd_icons/
45 }
46
47 do_install_append_vusolo4k() {
48         install -m 0755 ${WORKDIR}/skin_user_vusolo4k.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
49         install -d ${D}/usr/share/enigma2/lcd_icons/
50         install -m 0755 ${WORKDIR}/lcd_icons_vusolo4k/*.png ${D}/usr/share/enigma2/lcd_icons/
51 }
52