relocate packages on recipes-base/recipes-enigma2/recipes-wlan.
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / firmwares / marvell-gspi-fw_9.70.3-p37.bb
diff --git a/meta-openvuplus/recipes-vuplus/firmwares/marvell-gspi-fw_9.70.3-p37.bb b/meta-openvuplus/recipes-vuplus/firmwares/marvell-gspi-fw_9.70.3-p37.bb
new file mode 100644 (file)
index 0000000..9fdfd6f
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Firmware for Marvel 8686 gspi wifi chipset"
+LICENSE = "closed"
+
+SRC_URI = "file://${PV}.tar.gz \
+           file://Marvell-Licence.txt"
+
+S = "${WORKDIR}/${PV}/FwImage"
+
+do_install() {
+
+       install -d ${D}${base_libdir}/firmware
+       install -m 0644 gspi8686.bin helper_gspi.bin ${D}${base_libdir}/firmware
+       install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
+       ln -s helper_gspi.bin ${D}${base_libdir}/firmware/gspi8686_hlp.bin
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${base_libdir}/firmware"
+
+PACKAGE_ARCH = "all"