remove xinetd, systemd.
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-transtreamproxy.bb
index af394f3..cbe06f6 100644 (file)
@@ -2,27 +2,18 @@ SUMMARY = "streamproxy manages streaming data to a Mobile device using enigma2"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 SRCREV = "37a3f198a22d90cdfebf07cf56409cf93a4e74ba"
-PR = "r4"
+PR = "r5"
 
-SRC_URI = "file://transtreamproxy.xinetd.in \
-           file://transtreamproxy@.service \
-           file://transtreamproxy.socket \
+SRC_URI = " \
            file://transcoding.patch;patch=1;pnum=1 \
 "
 
 SCHWERKRAFT_PROJECT = "streamproxy"
 
-inherit autotools schwerkraft-git systemd xinetd
+inherit autotools schwerkraft-git
 
 do_install() {
         install -d ${D}/usr/bin
         install -m 0755 ${S}/src/streamproxy      ${D}/usr/bin/transtreamproxy
-        install -d ${D}${systemd_unitdir}/system
-        ln -sf /dev/null ${D}${systemd_unitdir}/system/transtreamproxy.service
 }
 
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE_${PN}-systemd = "transtreamproxy.socket"
-
-XINETD_PACKAGES = "${PN}-xinetd"
-XINETD_SERVICE_${PN}-xinetd = "transtreamproxy"