task-vuplus-enigma2 : add enigma2-plugins.
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
new file mode 100644 (file)
index 0000000..c4c6f9e
--- /dev/null
@@ -0,0 +1,29 @@
+MODULE = "OpenWebif"
+DESCRIPTION = "Control your receiver with a browser"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
+
+DEPENDS = "python-cheetah-native"
+RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc"
+
+inherit gitpkgv
+PV = "0.1+git${SRCPV}"
+PKGV = "0.1+git${GITPKGV}"
+PR = "r0.72"
+
+require openplugins.inc
+
+# Just a quick hack to "compile" it
+do_compile() {
+       cheetah-compile -R --nobackup ${S}/plugin
+       python -O -m compileall ${S}
+}
+
+PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
+do_install() {
+       install -d ${D}${PLUGINPATH}
+       cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
+}
+
+FILES_${PN} = "${PLUGINPATH}"
+PACKAGES = "${PN}"