dcc124e1d18fbff7d9274aedb300a3efc93870a7
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / sctzap / sctzap_cvs.bb
1 DESCRIPTION = "szap, czap, tzap are command-line based tools to tune in a DVB service"
2 SECTION = "console/multimedia"
3 PRIORITY = "optional"
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://szap.c;md5=7a5704804608206c59472a35cb35675f"
6 PV = "0.0+cvs${SRCDATE}"
7
8 SRC_URI = "cvs://anonymous@cvs.linuxtv.org/cvs/linuxtv;module=dvb-apps/util/szap \
9            cvs://anonymous@cvs.linuxtv.org/cvs/linuxtv;module=dvb-apps/util/lib"
10
11 S = "${WORKDIR}/szap"
12
13 CFLAGS_append = " -I../lib "
14
15 do_compile() {
16         oe_runmake szap czap tzap femon
17 }
18
19 do_install() {
20         mkdir -p ${D}${bindir}
21         install -m 0755 szap ${D}${bindir}/
22         install -m 0755 czap ${D}${bindir}/
23         install -m 0755 tzap ${D}${bindir}/
24         install -m 0755 femon ${D}${bindir}/
25 }