1f88e71a8bcf8d005ba9c58d7b4fb8c55857dffd
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / satipclient / satipclient.bb
1 DESCIPTION = "Support satip client using vtuner"
2 LICENSE = "CLOSED"
3
4 SRCDATE = "20150629"
5 SRCDATE_PR = "r0"
6 PR = "${SRCDATE}.${SRCDATE_PR}"
7
8 SRC_URI = " \
9         http://code.vuplus.com/download/build.fc3abf29fb03f797e78f907928125638/embedded/satipclient/satipclient_${SRCDATE}_${SRCDATE_PR}.tar.gz \
10         file://satipclient.sh \
11         "
12
13 inherit update-rc.d
14
15 INITSCRIPT_NAME = "${PN}"
16 INITSCRIPT_PARAMS = "defaults"
17
18 do_install_append() {
19         install -d ${D}/usr/bin
20         install -m 0755 ${WORKDIR}/satipclient ${D}/usr/bin
21         install -d ${D}/etc/init.d
22         install -m 0755 ${WORKDIR}/${PN}.sh ${D}/etc/init.d/${PN}
23 }
24
25 SRC_URI[md5sum] = "b907964a587c24e53c4a11486df36c1a"
26 SRC_URI[sha256sum] = "52afeb599a857e9db038f4c3cb84efd2093e6f62a29ade2e9ae5b32cdc67cc72"
27