Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / opera-hbbtv / opera-hbbtv_0.1.bb
1 DESCRIPTION = "opera-hbbtv"
2 PRIORITY = "required"
3 LICENSE = "CLOSED"
4
5 DEPENDS = "tslib mpfr gmp"
6 RDEPENS = "tslib-conf libts-1.0-0 libsysfs2 libgmp3 libmpfr1"
7
8 SRC_DATE = "20121128_1"
9
10 PR = "r1_${SRC_DATE}"
11 SRC_URI = "http://code.vuplus.com/download/build.fc3abf29fb03f797e78f907928125638/embedded/opera-sdk-build-package/opera-hbbtv_${SRC_DATE}.tar.gz"
12
13 INHIBIT_PACKAGE_STRIP = "1"
14 S = "${WORKDIR}/opera-hbbtv"
15 do_compile() {
16 }
17 do_install() {
18         install -d ${D}/usr/local/hbb-browser
19         mv ${S}/opera/* ${D}/usr/local/hbb-browser/
20         install -d ${D}/etc
21         mv ${S}/dfb/etc/* ${D}/etc/
22         install -d ${D}/usr/bin
23         mv ${S}/dfb/usr/bin/* ${D}/usr/bin/
24         install -d ${D}/usr/lib
25         mv ${S}/dfb/usr/lib/* ${D}/usr/lib/
26         install -d ${D}/usr/share
27         mv ${S}/dfb/usr/share/* ${D}/usr/share/
28         install -d ${D}/usr/lib/enigma2/python/Plugins/Extensions/HbbTV
29         mv ${S}/plugin/* ${D}/usr/lib/enigma2/python/Plugins/Extensions/HbbTV
30 }
31
32 PACKAGES = "${PN}"
33
34 FILES_${PN} = "/"
35
36 SRC_URI[md5sum] = "e534839ac1aedaf2bcdf0e5c277e631c"
37 SRC_URI[sha256sum] = "9738b06ed35632a675de0cf95bd123d7f9759927a96910c28294ee723fead181"