bug fixed ( after playing advertising, can't play a vod of SAT.1. )
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / opera-hbbtv / opera-hbbtv_0.1.bb
1 DESCRIPTION = "opera-hbbtv"
2 PRIORITY = "required"
3 LICENSE = "CLOSED"
4
5 DEPENDS = "tslib mpfr gmp"
6 RDEPENS = "tslib-conf libts-1.0-0 libsysfs2 libgmp3 libmpfr1"
7
8 SRC_DATE = "20130425_0"
9
10 PR = "r1_${SRC_DATE}"
11 SRC_URI = "http://code.vuplus.com/download/build.fc3abf29fb03f797e78f907928125638/embedded/opera-sdk-build-package/opera-hbbtv_${SRC_DATE}.tar.gz"
12
13 INHIBIT_PACKAGE_STRIP = "1"
14 S = "${WORKDIR}/opera-hbbtv"
15 do_compile() {
16 }
17 do_install() {
18         rm -f ${S}/opera/lib/libopera.so
19         install -d ${D}/usr/local/hbb-browser
20         mv ${S}/opera/* ${D}/usr/local/hbb-browser/
21         install -d ${D}/etc
22         mv ${S}/dfb/etc/* ${D}/etc/
23         install -d ${D}/usr/bin
24         mv ${S}/dfb/usr/bin/* ${D}/usr/bin/
25         install -d ${D}/usr/lib
26         mv ${S}/dfb/usr/lib/* ${D}/usr/lib/
27         install -d ${D}/usr/share
28         mv ${S}/dfb/usr/share/* ${D}/usr/share/
29         install -d ${D}/usr/lib/enigma2/python/Plugins/Extensions/HbbTV
30         mv ${S}/plugin/* ${D}/usr/lib/enigma2/python/Plugins/Extensions/HbbTV
31 }
32
33 do_package_qa() {
34 }
35
36 PACKAGES = "${PN}"
37
38 FILES_${PN} = "/"
39
40 SRC_URI[md5sum] = "2e16afc3db22f80cf99de3bfb891fa06"
41 SRC_URI[sha256sum] = "41bbf4cda0b19ca7c79cb06ec4ab8cafee62fd9944d17e71978d4c9e6d72d264"
42