enigma2 : fix typo.
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=c9e255efa454e0155c1fd758df7dcaf3"
5 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
6         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
7         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
8         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi \
9         hostap-daemon bridge-utils ntfs-3g dosfstools util-linux \
10 "
11
12 RDEPENDS_GST= "gst-plugins-base-decodebin gst-plugins-base-decodebin2 gst-plugins-base-app gst-plugins-bad-fragmented \
13                 gst-plugins-good-id3demux gst-plugins-ugly-mad gst-plugins-base-ogg gst-plugins-base-playbin \
14                 gst-plugins-base-typefindfunctions gst-plugins-base-audioconvert gst-plugins-base-audioresample \
15                 gst-plugins-good-wavparse gst-plugins-ugly-mpegstream \
16                 gst-plugins-good-flac gst-plugin-dvbmediasink gst-plugins-bad-mpegdemux gst-plugins-ugly-dvdsub \
17                 gst-plugins-good-souphttpsrc gst-plugins-ugly-mpegaudioparse gst-plugins-base-subparse \
18                 gst-plugins-good-apetag gst-plugins-good-icydemux gst-plugins-good-autodetect gst-plugins-good-flv \
19 "
20
21 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
22                 python-xml python-fcntl python-stringold python-pickle python-netclient \
23                 glibc-gconv-iso8859-15 ethtool \
24                 ${RDEPENDS_GST} \
25 "
26
27 GST_RTSP_RDEPENDS = "gst-plugins-good-udp gst-plugins-good-rtsp gst-plugins-good-rtp gst-plugins-good-rtpmanager"
28 GST_ALSA_RDEPENDS = "gst-plugins-base-alsa alsa-conf"
29 GST_MISC_RDEPENDS = "gst-plugins-good-matroska gst-plugins-good-isomp4 gst-plugins-base-vorbis gst-plugins-good-audioparsers"
30 GST_DVD_RDEPENDS = "gst-plugins-bad-cdxaparse gst-plugins-ugly-cdio gst-plugins-bad-vcdsrc"
31 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
32
33 RDEPENDS_append_vuplus = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugins-good-avi"
34
35 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
36 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
37 #DEPENDS += "enigma2-plugins"
38 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
39
40 SUMMARY_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
41 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
42 SUMMARY_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
43 SUMMARY_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
44 SUMMARY_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
45 SUMMARY_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
46 SUMMARY_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
47 SUMMARY_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
48 SUMMARY_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
49 SUMMARY_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
50 DEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
51 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "python-twisted-web"
52 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "python-twisted-web"
53 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
54 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
55 SUMMARY_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
56 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "python-twisted-mail python-twisted-names python-compression python-mime python-email"
57 SUMMARY_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
58 SUMMARY_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
59 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
60 SUMMARY_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
61 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
62 SUMMARY_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
63 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
64 SUMMARY_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
65 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
66 SUMMARY_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
67 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "python-twisted-mail python-twisted-names python-compression python-mime python-email"
68 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
69
70 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugins-bad-rtmp "
71
72 DEPENDS += "djmount minidlna"
73 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna "
74 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount kernel-module-fuse fuse-utils"
75
76 DEPENDS += "opera-hbbtv"
77 RDEPENDS_enigma2-plugin-extensions-hbbtv = "opera-hbbtv"
78
79 DEPENDS += "wvdial wvstreams ppp usb-modeswitch usb-modeswitch-data"
80 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usb-modeswitch usb-modeswitch-data wvdial wvstreams \
81         kernel-module-ppp-async kernel-module-ppp-deflate kernel-module-ppp-synctty kernel-module-ppp-generic kernel-module-usbserial \
82 "
83
84
85 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-blkid ntfs-3g dosfstools"
86
87 PN = "enigma2"
88 PR = "r5"
89
90 SRCDATE = "20121128"
91 #SRCDATE is NOT used by git to checkout a specific revision
92 #but we need it to build a ipk package version
93 #when you like to checkout a specific revision of e2 you need
94 #have to specify a commit id or a tag name in SRCREV
95
96 ####################################################
97 BRANCH = "vuplus_experimental"
98 PV = "experimental-git${SRCDATE}"
99 SRCREV = ""
100 ####################################################
101
102 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
103
104 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
105            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
106            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
107            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
108            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
109            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
110            file://enigma2_vuplus_addlibpythondeps.patch;patch=1;pnum=1 \
111            file://enigma2_vuplus_pluginbrowser.patch;striplevel=1 \
112            file://enigma2_vuplus_transcodingsetup_inetd.patch;striplevel=1 \
113            file://MyriadPro-Regular.otf \
114            file://MyriadPro-Semibold.otf \
115            file://MyriadPro-SemiboldIt.otf \
116            file://750S \
117            file://Vu_HD \
118            file://number_key \
119            "
120
121 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
122
123 def change_po():
124         import os
125         try:
126                 os.system("find ./ -name \"*.po\" > ./po_list")
127                 os.system("find ./ -name \"*.pot\" >> ./po_list")
128                 po_list = []
129                 po_list = open('po_list','r+').readlines()
130                 for x in po_list:
131                         changeword(x)
132                 os.system('rm po_list')
133         except:
134                 print 'word patch error '
135                 return
136
137 def changeword(file):
138         fn = file[:-1]
139         fnn = file[:-1]+'_n'
140         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
141         os.system(cmd)
142         cmd1 = "mv "+fnn+" "+fn
143         os.system(cmd1)
144
145 do_unpack_append(){
146         change_po()
147 }
148
149 S = "${WORKDIR}/git"
150
151 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
152 FILES_${PN}-meta = "${datadir}/meta"
153 PACKAGES += "${PN}-meta"
154 PACKAGE_ARCH = "${MACHINE_ARCH}"
155
156 inherit autotools pkgconfig
157
158 do_configure_prepend() {
159         git checkout ${BRANCH}
160 }
161
162 do_compile_prepend_vuplus() {
163         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
164         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
165         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
166         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
167         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
168         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
169         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
170         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
171         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
172         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
173         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
174         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
175         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
176         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
177         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
178 }
179
180 EXTRA_OECONF = " \
181         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
182         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
183         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
184         ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
185         BUILD_SYS=${BUILD_SYS} \
186         HOST_SYS=${HOST_SYS} \
187         STAGING_INCDIR=${STAGING_INCDIR} \
188         STAGING_LIBDIR=${STAGING_LIBDIR} \
189 "
190
191 python populate_packages_prepend() {
192         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
193         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/[a-zA-Z0-9_]+.*$', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
194         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
195         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
196         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/(.*/)?\.debug/.*$', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
197 }
198
199 RCONFLICTS_${PN} = "dreambox-keymaps"
200 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
201