7f5188a6081a7ab57f9744e9806f411057fc2396
[vuplus_openvuplus] / meta-openvuplus / recipes-vuplus / dreambox-dvbincludes / dreambox-dvbincludes.bb
1 SUMMARY = "This package provides dbox2/dreambox \
2 compatible header files for the API to the drivers."
3
4 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
5
6 PV="1"
7 LICENSE = "GPLv2+"
8 LIC_FILES_CHKSUM = "file://dbox/avs_core.h;beginline=1;endline=21;md5=b2ab401756a0768647ae13acb2e325ab"
9
10 SRC_URI = "http://sources.dreamboxupdate.com/snapshots/include2.tar.gz"
11 SRC_URI[md5sum] = "9d236095a88d7ce9f3bf0503ee5237d6"
12 SRC_URI[sha256sum] = "739bc35bccdb1e4c6e14b77ab86808354eb6fd75434d3bd6236f3b3346805e02"
13
14 S = "${WORKDIR}/include"
15
16 ALLOW_EMPTY_dreambox-dvbincludes = "1"
17
18 INPUT_FILES = "input_fake.h ci/ci.h  dbox/avia_gt_pig.h dbox/avs_core.h \
19         dbox/event.h dbox/fp.h dbox/info.h dbox/lcd.h dbox/saa7126_core.h \
20         dbox/lcd-ks0713.h dbox/fb.h \
21         dreambox/dreaminfo.h \
22         tuxbox/hardware_dbox2.h tuxbox/hardware_dreambox.h tuxbox/hardware_pci.h \
23         tuxbox/info.h tuxbox/info_dbox2.h tuxbox/kernel.h"
24
25 do_install() {
26         install -d ${STAGING_INCDIR}/ci
27         install -d ${STAGING_INCDIR}/dbox
28         install -d ${STAGING_INCDIR}/dreambox
29         install -d ${STAGING_INCDIR}/tuxbox
30         for f in ${INPUT_FILES}; do
31                 install -m 0644 ${S}/$f ${STAGING_INCDIR}/$f
32         done;
33 }
34