update gstreamer/base/good/bad/ugly SRCREV
[vuplus_openvuplus] / meta-openvuplus / recipes-multimedia / gstreamer / gst-plugins-bad_0.10.23.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+ "
4 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
5                     file://gst/tta/filters.h;beginline=12;endline=29;md5=629b0c7a665d155a6677778f4460ec06 \
6                     file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
7                     file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c"
8
9 DEPENDS += "libmusicbrainz tremor curl libmms librtmp"
10 DEPENDS += "gst-plugins-base"
11 CONFLICTS = "librsvg"
12
13 PR = "r2"
14 GIT_PV = ""
15
16 SRCREV = "fb0d8700e71c4a6569ba023d16201087aec119fd"
17
18 EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio --disable-directfb \
19                  --disable-vdpau --disable-apexsink --enable-orc --disable-mpeg2enc --disable-mplex --disable-rsvg --disable-uvch264"
20
21 ARM_INSTRUCTION_SET = "arm"
22
23 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
24
25 SRC_URI += " \
26         file://0003-mpegpsdemux_speedup.diff.patch \
27         file://0004-mpegdemux-compile-fixes.patch \
28         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
29 "
30
31 inherit autotools pkgconfig gettext git-project
32
33 do_common_update() {
34         cd ${S}
35         # Make sure we have common
36         if test ! -f common/gst-autogen.sh;
37         then
38           echo "+ Setting up common submodule"
39           git submodule init
40         fi
41         git submodule update
42
43         # source helper functions
44         if test ! -f common/gst-autogen.sh;
45         then
46           echo There is something wrong with your source tree.
47           echo You are missing common/gst-autogen.sh
48           exit 1
49         fi
50         . common/gst-autogen.sh
51         # install pre-commit hook for doing clean commits
52         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
53         then
54             rm -f .git/hooks/pre-commit
55             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
56         fi
57
58         # GNU gettext automake support doesn't get along with git.
59         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
60         autopoint || touch config.rpath
61         touch -t 200001010000 po/gst-plugins-base-0.10.pot
62 }
63 addtask common_update after do_unpack before do_patch
64
65 do_configure_prepend() {
66         # This m4 file contains nastiness which conflicts with libtool 2.2.2
67         rm ${S}/m4/lib-link.m4 || true
68 }
69
70 require mips-only.inc