Use linux-libc-headers-2.6.31/udev-124
[vuplus_openvuplus] / meta-openvuplus / recipes-kernel / linux-libc-headers / linux-libc-headers_2.6.31.bb
1 DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
2 SECTION = "devel"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6 PR = "r0"
7
8 DEPENDS += "unifdef-native"
9 RDEPENDS_${PN}-dev = ""
10 RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPV})"
11
12 INHIBIT_DEFAULT_DEPS = "1"
13 DEFAULT_PREFERENCE = "-1"
14
15 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
16            file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
17            file://dvbapi-5.3.patch;patch=1;pnum=1 \
18 "
19
20 SRC_URI[md5sum] = "84c077a37684e4cbfa67b18154390d8a"
21 SRC_URI[sha256sum] = "0acd83f7b85db7ee18c2b0b7505e1ba6fd722c36f49a8870a831c851660e3512"
22   
23 S = "${WORKDIR}/linux-${PV}"
24
25 set_arch() {
26         case ${TARGET_ARCH} in
27                 alpha*)   ARCH=alpha ;;
28                 arm*)     ARCH=arm ;;
29                 cris*)    ARCH=cris ;;
30                 hppa*)    ARCH=parisc ;;
31                 i*86*)    ARCH=i386 ;;
32                 ia64*)    ARCH=ia64 ;;
33                 mips*)    ARCH=mips ;;
34                 m68k*)    ARCH=m68k ;;
35                 powerpc*) ARCH=powerpc ;;
36                 s390*)    ARCH=s390 ;;
37                 sh*)      ARCH=sh ;;
38                 sparc64*) ARCH=sparc64 ;;
39                 sparc*)   ARCH=sparc ;;
40                 x86_64*)  ARCH=x86_64 ;;
41                 avr32*)   ARCH=avr32 ;;
42                 bfin*)    ARCH=blackfin ;;
43         esac
44 }
45
46 do_configure() {
47         set_arch
48         oe_runmake allnoconfig ARCH=$ARCH
49 }
50
51 do_compile () {
52 }
53
54 do_install() {
55         set_arch
56         oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
57         # Kernel should not be exporting this header
58         rm -rf ${D}${includedir}/scsi
59
60         # The ..install.cmd conflicts between various configure runs
61         #find ${D}${includedir} -name ..install.cmd | xargs rm -f
62 }
63
64 BBCLASSEXTEND = "nativesdk"