modify FactoryTest plugin.
[vuplus_dvbapp] / tools / Makefile.am
index ff74357..82301a6 100644 (file)
@@ -1,6 +1,9 @@
-lib_LTLIBRARIES = libopen.la
+libopen.so.0.0: libopen.c
+       $(CXX) -Wall -W libopen.c -O2 -nostartfiles -shared -fPIC -Wl,-soname,libopen.so.0 -o libopen.so.0.0 -ldl
 
-libopen_la_SOURCES = libopen.c
+all: libopen.so.0.0
 
-install-exec-local:
-$(LIBTOOL) --mode=install install libopen.la $(DESTDIR)/usr/lib
\ No newline at end of file
+CLEANFILES = libopen.so.0.0
+
+install: all
+       $(INSTALL) libopen.so.0.0 $(DESTDIR)/usr/lib