configure: disable updates of po files if --without-po is given
[vuplus_dvbapp] / po / Makefile.am
index 53e65ae..e7318f7 100644 (file)
@@ -6,6 +6,7 @@ LANGPO = $(LANGS:=.po)
 
 EXTRA_DIST = $(LANGPO)
 
+if UPDATE_PO
 # the TRANSLATORS: allows putting translation comments before the to-be-translated line.
 enigma2-py.pot: $(top_srcdir)/*.py $(top_srcdir)/lib/python/*/*.py $(top_srcdir)/lib/python/Plugins/*/*/*.py
        $(XGETTEXT) -L Python --from-code=UTF-8 --add-comments="TRANSLATORS:" -d @PACKAGE_NAME@ -s -o $@ $^
@@ -22,6 +23,7 @@ enigma2.pot: enigma2-py.pot enigma2-xml.pot
        else \
                $(MSGINIT) -l $@ -o $@ -i $< --no-translator; \
        fi
+endif
 
 .po.mo:
        $(MSGFMT) -o $@ $<