TranscodingSetup : fix misspelling name.
[vuplus_dvbapp] / lib / python / Plugins / SystemPlugins / TransCodingSetup / locale / Makefile.am
diff --git a/lib/python/Plugins/SystemPlugins/TransCodingSetup/locale/Makefile.am b/lib/python/Plugins/SystemPlugins/TransCodingSetup/locale/Makefile.am
new file mode 100644 (file)
index 0000000..9b6033c
--- /dev/null
@@ -0,0 +1,28 @@
+PLUGIN = TransCodingSetup
+LANGS = de
+
+CATEGORY ?= "SystemPlugins"
+
+plugindir = $(libdir)/enigma2/python/Plugins/$(CATEGORY)/$(PLUGIN)
+
+LANGMO = $(LANGS:=.mo)
+LANGPO = $(LANGS:=.po)
+
+.po.mo:
+       $(MSGFMT) -o $@ $<
+
+BUILT_SOURCES = $(LANGMO)
+CLEANFILES = $(LANGMO) $(PLUGIN)-py.pot $(PLUGIN)-xml.pot $(PLUGIN).pot
+
+dist-hook: $(LANGPO)
+
+install-data-local: $(LANGMO)
+       for lang in $(LANGS); do \
+               $(mkinstalldirs) $(DESTDIR)$(plugindir)/locale/$$lang/LC_MESSAGES; \
+               $(INSTALL_DATA) $$lang.mo $(DESTDIR)$(plugindir)/locale/$$lang/LC_MESSAGES/$(PLUGIN).mo; \
+       done
+
+uninstall-local:
+       for lang in $(LANGS); do \
+               $(RM) $(DESTDIR)$(plugindir)/locale/$$lang/LC_MESSAGES/$(PLUGIN).mo; \
+       done