fixes bug #593
[vuplus_dvbapp] / lib / python / Makefile.am
index e94d36f..e38f7d8 100644 (file)
@@ -2,7 +2,7 @@ INCLUDES = \
        -I$(top_srcdir)/include \
        -I$(top_srcdir)/src
 
-SUBDIRS = Components Tools Screens
+SUBDIRS = Components Tools Screens Plugins
 
 noinst_LIBRARIES = libenigma_python.a
 
@@ -10,9 +10,14 @@ libenigma_python_a_SOURCES = \
        python.cpp enigma_python_wrap.cxx connections.cpp
 
 enigma_python_wrap.cxx: enigma_python.i
-       swig -I$(top_srcdir)/ -c++ -python enigma_python.i
+       swig -I$(top_srcdir)/ -c++ -python -O -nortti -nothreads enigma_python.i
+       python enigma_py_patcher.py
 
-installdir = $(LIBDIR)/enigma2/python
+enigma.py: enigma_python_wrap.cxx
 
-install_DATA = \
+CLEANFILES = enigma.py enigma_python_wrap.cxx
+
+installdir = $(pkglibdir)/python
+
+install_PYTHON = \
        enigma.py