NFIFlash: hide hdd and other mounts (#480)
[vuplus_dvbapp] / lib / python / Makefile.am
index dbcf489..e38f7d8 100644 (file)
@@ -2,16 +2,22 @@ INCLUDES = \
        -I$(top_srcdir)/include \
        -I$(top_srcdir)/src
 
+SUBDIRS = Components Tools Screens Plugins
+
 noinst_LIBRARIES = libenigma_python.a
 
 libenigma_python_a_SOURCES = \
        python.cpp enigma_python_wrap.cxx connections.cpp
 
 enigma_python_wrap.cxx: enigma_python.i
-       swig -I$(top_srcdir)/ -c++ -python enigma_python.i
+       swig -I$(top_srcdir)/ -c++ -python -O -nortti -nothreads enigma_python.i
+       python enigma_py_patcher.py
+
+enigma.py: enigma_python_wrap.cxx
+
+CLEANFILES = enigma.py enigma_python_wrap.cxx
 
-enigma_python.i: enigma_iobject.i
+installdir = $(pkglibdir)/python
 
-enigma_iobject.i:
-       find ../../.. -name "*.cpp" | xargs grep -h "DEFINE_REF" > enigma_iobject.i
-       
\ No newline at end of file
+install_PYTHON = \
+       enigma.py