clean up build #2
[vuplus_dvbapp] / lib / python / Makefile.am
index 03dcedb..3c213a1 100644 (file)
@@ -1,18 +1,30 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/include \
-       -include Python.h
+       -include Python.h \
+       -include $(top_builddir)/enigma2_config.h
 
 SUBDIRS = Components Tools Screens Plugins
 
 noinst_LTLIBRARIES = libenigma_python.la
 
 libenigma_python_la_SOURCES = \
-       python.cpp enigma_python_wrap.cxx connections.cpp
+       connections.cpp \
+       connections.h \
+       python.cpp \
+       python.h \
+       swig.h
 
-enigma_python_wrap.cxx: enigma_python.i
-       swig -I$(top_srcdir)/ -c++ -python -O -nortti -nothreads enigma_python.i
-       python enigma_py_patcher.py
+nodist_libenigma_python_la_SOURCES = \
+       enigma_python_wrap.cxx
+
+EXTRA_DIST = \
+       enigma_py_patcher.py \
+       enigma_python.i
+
+enigma_python_wrap.cxx: $(srcdir)/enigma_python.i
+       $(SWIG) $(AX_SWIG_PYTHON_OPT) -I$(top_srcdir) -O -nortti -nothreads -o $@ $<
+       $(PYTHON) $(srcdir)/enigma_py_patcher.py
 
 enigma.py: enigma_python_wrap.cxx
 
@@ -22,3 +34,4 @@ installdir = $(pkglibdir)/python
 
 install_PYTHON = \
        enigma.py
+