HDMICEC : add new plugin
[vuplus_dvbapp] / lib / driver / Makefile.am
old mode 100644 (file)
new mode 100755 (executable)
index 74d24fa..a781229
@@ -4,23 +4,37 @@ AM_CPPFLAGS = \
        -include Python.h \
        -include $(top_builddir)/enigma2_config.h
 
-noinst_LTLIBRARIES = libenigma_driver.la
+AM_CXXFLAGS = \
+       $(LIBSDL_CFLAGS)
 
-libenigma_driver_la_SOURCES = \
+noinst_LIBRARIES = libenigma_driver.a
+
+libenigma_driver_a_SOURCES = \
        avswitch.cpp \
-       avswitch.h \
        etimezone.cpp \
+       misc_options.cpp \
+       rc.cpp \
+       rcconsole.cpp \
+       rcinput.cpp \
+       rfmod.cpp \
+       hdmi_cec.cpp
+
+driverincludedir = $(pkgincludedir)/lib/driver
+driverinclude_HEADERS = \
+       avswitch.h \
        etimezone.h \
        input_fake.h \
-       misc_options.cpp \
        misc_options.h \
-       rc.cpp \
        rc.h \
-       rcconsole.cpp \
        rcconsole.h \
        rcdbox.h \
        rcdreambox2.h \
-       rcinput.cpp \
        rcinput.h \
-       rfmod.cpp \
-       rfmod.h
+       rfmod.h \
+       hdmi_cec.h
+
+if HAVE_LIBSDL
+libenigma_driver_a_SOURCES += \
+       rcsdl.cpp \
+       rcsdl.h
+endif