install idatasource.h
[vuplus_dvbapp] / lib / base / Makefile.am
index 652ef9c..7f04abf 100644 (file)
@@ -8,45 +8,49 @@ noinst_LIBRARIES = libenigma_base.a
 
 libenigma_base_a_SOURCES = \
        buffer.cpp \
-       buffer.h \
        connection.cpp \
        console.cpp \
-       console.h \
        ebase.cpp \
-       ebase.h \
        eenv.cpp \
-       eenv.h \
        eerror.cpp \
-       eerror.h \
        elock.cpp \
-       elock.h \
        encoding.cpp \
+       estring.cpp \
+       etpm.cpp \
+       filepush.cpp \
+       init.cpp \
+       ioprio.cpp \
+       message.cpp \
+       nconfig.cpp \
+       rawfile.cpp \
+       smartptr.cpp \
+       thread.cpp
+
+EXTRA_DIST = \
+       eenv.cpp.in
+
+baseincludedir = $(pkgincludedir)/lib/base
+baseinclude_HEADERS = \
+       buffer.h \
+       console.h \
+       ebase.h \
+       eenv.h \
+       eerror.h \
+       elock.h \
        encoding.h \
        eptrlist.h \
-       estring.cpp \
        estring.h \
-       etpm.cpp \
        etpm.h \
-       filepush.cpp \
        filepush.h \
        i18n.h \
-       init.cpp \
+       idatasource.h \
        init.h \
        init_num.h \
-       ioprio.cpp \
        ioprio.h \
-       message.cpp \
        message.h \
-       nconfig.cpp \
        nconfig.h \
        object.h \
-       rawfile.cpp \
        rawfile.h \
        ringbuffer.h \
-       smartptr.cpp \
        smartptr.h \
-       thread.cpp \
        thread.h
-
-EXTRA_DIST = \
-       eenv.cpp.in