clean up build
[vuplus_dvbapp] / lib / base / Makefile.am
index df6d2b8..5fd3eaf 100644 (file)
@@ -1,9 +1,11 @@
 AM_CPPFLAGS = \
-       -I$(top_srcdir)/include
+       -I$(top_srcdir) \
+       -I$(top_srcdir)/include \
+       -include Python.h
 
-noinst_LIBRARIES = libenigma_base.a
+noinst_LTLIBRARIES = libenigma_base.la
 
-libenigma_base_a_SOURCES = \
+libenigma_base_la_SOURCES = \
        buffer.cpp ebase.cpp eerror.cpp elock.cpp \
        init.cpp message.cpp thread.cpp \
        smartptr.cpp estring.cpp connection.cpp \