xserver-common 1.13: Add patch to skip touchscreen calibration if there's no TS.
authorPaul Sokolovsky <pmiscml@gmail.com>
Fri, 9 Feb 2007 18:15:22 +0000 (18:15 +0000)
committerPaul Sokolovsky <pmiscml@gmail.com>
Fri, 9 Feb 2007 18:15:22 +0000 (18:15 +0000)
* Fixes GPE startup on TS-less machines like efika, qemu-arm, x86, lots of others.

packages/xserver-common/files/calibrate-only-if-ts.patch [new file with mode: 0644]
packages/xserver-common/xserver-common_1.13.bb

diff --git a/packages/xserver-common/files/calibrate-only-if-ts.patch b/packages/xserver-common/files/calibrate-only-if-ts.patch
new file mode 100644 (file)
index 0000000..7be808b
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/run-calibrate.sh.org     2006-10-12 10:19:42.000000000 +0000
++++ b/run-calibrate.sh 2007-02-09 17:54:55.000000000 +0000
+@@ -1,3 +1,5 @@
+ #! /bin/sh
+-exec xtscal
++if [ -e /dev/input/touchscreen0 ]; then
++    exec xtscal
++fi
index b051b5a..ebe54ec 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and support files"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
-PR = "r1"
+PR = "r2"
 
 PACKAGE_ARCH = "all"
 
@@ -10,7 +10,8 @@ PACKAGE_ARCH = "all"
 inherit gpe
 
 SRC_URI_append = " file://setDPI.sh \
-                   file://xserver-imageon.patch;patch=1"
+                   file://xserver-imageon.patch;patch=1 \
+                   file://calibrate-only-if-ts.patch;patch=1"
 
 do_install_append() {
        install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"