liburi-perl: direct PERL_ARCHLIB to STAGING_LIBDIR_NATIVE, instead of the host env
authorJunqian Gordon Xu <xjqian@gmail.com>
Mon, 4 Aug 2008 17:38:50 +0000 (17:38 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Mon, 4 Aug 2008 17:38:50 +0000 (17:38 +0000)
* CAVEAT: perl/5.8.8 has to be hard coded, needs to be updated with each new perl version

packages/perl/liburi-perl_1.35.bb

index 23116ac..5c1c427 100644 (file)
@@ -2,10 +2,14 @@ DESCRIPTION = "Manipulates and accesses URI strings"
 SECTION = "libs"
 LICENSE = "Artistic|GPL"
 #RDEPENDS += " libmime-base64-perl libnet-perl"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
 
 S = "${WORKDIR}/URI-${PV}"
 
 inherit cpan
+
+do_configure_append() {
+    sed -i -e "s|PERL_ARCHLIB = /usr/lib/perl/5.8|PERL_ARCHLIB = ${STAGING_LIBDIR_NATIVE}/perl/5.8.8|" Makefile
+}