merge of 4ed0964b486b99773aa438f582fa52d0b4e9b0d1
authorKoen Kooi <koen@openembedded.org>
Wed, 22 Feb 2006 10:58:26 +0000 (10:58 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 22 Feb 2006 10:58:26 +0000 (10:58 +0000)
     and 95868ff13ffd9c5a92e6e0ae4637b3e07e4a626d

15 files changed:
classes/tinderclient.bbclass
conf/bitbake.conf
packages/altboot/altboot.bb [deleted file]
packages/altboot/altboot_0.0.0.bb [new file with mode: 0644]
packages/altboot/altboot_0.0.5-rc2.bb [new file with mode: 0644]
packages/altboot/files/akita/altboot-2.6.cfg
packages/antlr/antlr-native_2.7.5.bb
packages/autoconf/autoconf-native_2.59.bb
packages/automake/automake-native.inc
packages/automake/automake-native_1.8.2.bb
packages/automake/automake-native_1.8.4.bb
packages/automake/automake_1.7.7.bb
packages/quilt/quilt-native_0.39.bb
packages/quilt/quilt-native_0.42.bb
packages/tslib/tslib_cvs.bb

index d01bce1..67cd958 100644 (file)
@@ -84,7 +84,7 @@ def tinder_build_start(d):
 
     selector = url + "/xml/build_start.pl"
 
-    print "selector %s and url %s" % (selector, url)
+    #print "selector %s and url %s" % (selector, url)
 
     # now post it
     h = httplib.HTTP(server)
@@ -94,7 +94,7 @@ def tinder_build_start(d):
     h.endheaders()
     h.send(body)
     errcode, errmsg, headers = h.getreply()
-    print errcode, errmsg, headers
+    #print errcode, errmsg, headers
     report = h.file.read()
 
     # now let us find the machine id that was assigned to us
@@ -134,8 +134,8 @@ def tinder_send_http(d, status, log):
     h.endheaders()
     h.send(body)
     errcode, errmsg, headers = h.getreply()
-    print errcode, errmsg, headers
-    print h.file.read()
+    #print errcode, errmsg, headers
+    #print h.file.read()
 
 
 def tinder_print_info(d):
@@ -161,6 +161,7 @@ def tinder_print_info(d):
     bbfiles = data.getVar( 'BBFILES', d, True )
     tarch   = data.getVar( 'TARGET_ARCH', d, True )
     fpu     = data.getVar( 'TARGET_FPU', d, True )
+    oerev   = data.getVar( 'OE_REVISION', d, True ) or "unknown"
 
     # there is a bug with tipple quoted strings
     # i will work around but will fix the original
@@ -184,6 +185,7 @@ def tinder_print_info(d):
     output.append("MACHINE = '%(machine)s'" )
     output.append("DISTRO = '%(distro)s'" )
     output.append("BBFILES = '%(bbfiles)s'" )
+    output.append("OEREV = '%(oerev)s'" )
     output.append("== End Tinderbox Client Info" )
 
     # now create the real output
@@ -227,6 +229,7 @@ def tinder_tinder_start(d):
     output.append( config )
     output.append( env    )
     output.append( "<--- TINDERBOX FINISHED PRINTING CONFIGURATION %(time_end)s" )
+    output.append( "" )
     return "\n".join(output) % vars()
 
 def tinder_do_tinder_report(event):
@@ -270,23 +273,24 @@ def tinder_do_tinder_report(event):
 
         if len(log_file) != 0:
             to_file  = data.getVar('TINDER_LOG', event.data, True)
-            log      = open(log_file[0], 'r').readlines()
+            log     += "\n".join(open(log_file[0], 'r').readlines())
 
     # set the right 'HEADER'/Summary for the TinderBox
     if name == "TaskStarted":
-        log += "--> TINDERBOX Task %s started" % event.task
+        log += "---> TINDERBOX Task %s started\n" % event.task
     elif name == "TaskSucceeded":
-        log += "<-- TINDERBOX Task %s done (SUCCESS)" % event.task
+        log += "<--- TINDERBOX Task %s done (SUCCESS)\n" % event.task
     elif name == "TaskFailed":
-        log += "<-- TINDERBOX Task %s failed (FAILURE)" % event.task
+        log += "<--- TINDERBOX Task %s failed (FAILURE)\n" % event.task
     elif name == "PkgStarted":
-        log += "--> TINDERBOX Package %s started" % data.getVar('P', event.data, True)
+        log += "---> TINDERBOX Package %s started\n" % data.getVar('P', event.data, True)
     elif name == "PkgSucceeded":
-        log += "<-- TINDERBOX Package %s done (SUCCESS)" % data.getVar('P', event.data, True)
+        log += "<--- TINDERBOX Package %s done (SUCCESS)\n" % data.getVar('P', event.data, True)
     elif name == "PkgFailed":
-        log += "<-- TINDERBOX Package %s failed (FAILURE)" % data.getVar('P', event.data, True)
+        log += "<--- TINDERBOX Package %s failed (FAILURE)\n" % data.getVar('P', event.data, True)
         status = 200
     elif name == "BuildCompleted":
+       log += "Build Completed\n"
         status = 100
 
     # now post the log
index 98c2002..2b5856e 100644 (file)
@@ -72,7 +72,7 @@ DATETIME = "${DATE}${TIME}"
 
 # python-native should be here but python relies on building 
 # its own in staging
-ASSUME_PROVIDED = "cvs-native svn-native"
+ASSUME_PROVIDED = "cvs-native svn-native bzip2-native diffstat-native patch-native"
 
 ##################################################################
 # Package default variables.
diff --git a/packages/altboot/altboot.bb b/packages/altboot/altboot.bb
deleted file mode 100644 (file)
index ce586f6..0000000
+++ /dev/null
@@ -1,98 +0,0 @@
-DESCRIPTION = "A text-based bootmanager allowing a Zaurus to boot from SD, CF, USB-Storage and NFS. \
-Tested machines: Collie, Poodle, Akita, Spitz"
-SECTION = "base"
-PRIORITY = "optional"
-MAINTAINER = "Matthias 'CoreDump' Hentges  <oe@hentges.net>"
-LICENSE = "GPL"
-IGNORE_STRIP_ERRORS = "1"
-
-PR = "r20"
-
-
-SRC_URI = "file://altboot-menu \
-          file://altboot.rc \
-          file://altboot.func \         
-          file://init.altboot \
-          file://altboot*.cfg"
-
-# S = "${WORKDIR}/files"
-do_install() {
-       install -d ${D}/sbin
-       install -d ${D}/etc/altboot-menu
-       install -d ${D}/etc/altboot-menu/Advanced
-       install -d ${D}/etc/altboot.rc
-       install -d ${D}/usr/share/doc/altboot
-       
-       install -m 0644 ${WORKDIR}/altboot*.cfg ${D}/etc
-       install -m 0644 ${WORKDIR}/altboot.func ${D}/etc
-#      install -m 0644 ${WORKDIR}/docs/altboot/*.txt ${D}/usr/share/doc/altboot
-       install -m 0755 ${WORKDIR}/init.altboot ${D}/sbin       
-       install -m 0755 ${WORKDIR}/altboot-menu/*-* ${D}/etc/altboot-menu
-       install -m 0755 ${WORKDIR}/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
-       install -m 0755 ${WORKDIR}/altboot.rc/*.sh ${D}/etc/altboot.rc
-       install -m 0644 ${WORKDIR}/altboot.rc/*.txt ${D}/etc/altboot.rc 
-}              
-
-
-
-pkg_postinst() {
-       update-alternatives --install /sbin/init init /sbin/init.altboot 55
-}
-
-pkg_postinst_spitz() {
-       # Note: Spitz support is a royal pain in the ass.
-       #       Since Spitz pivot_roots by default, there is no real way
-       #       a user can install an altboot.ipk into the flash FS.
-       #       So we need to do that manually (*SIGH*)
-
-       # /l/m only exists on the HDD on spitz
-       if test -d /lib/modules
-       then
-          if [ -e /media/realroot/sbin/init ]; then
-             ROOT_MOUNT_POINT="/media/realroot"
-          elif [ -e /media/ROM/sbin/init ]; then
-             ROOT_MOUNT_POINT="/media/ROM"
-          fi
-          if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
-             ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
-             if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
-                mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
-                cp -R /etc/altboot* $ROOT_MOUNT_POINT/etc
-                cp /sbin/init.altboot $ROOT_MOUNT_POINT/sbin
-                if [ -f $ROOT_MOUNT_POINT/sbin/init ]; then
-                        mv $ROOT_MOUNT_POINT/sbin/init $ROOT_MOUNT_POINT/sbin/init.orig
-                fi
-                ln -s /sbin/init.altboot $ROOT_MOUNT_POINT/sbin/init
-             fi
-          fi
-       fi
-}
-
-pkg_postrm() {
-       update-alternatives --remove init /sbin/init.altboot
-}
-
-pkg_postrm_spitz() {
-       if test -d /lib/modules
-        then
-           if [ -e /media/realroot/sbin/init ]; then
-              ROOT_MOUNT_POINT="/media/realroot"
-           elif [ -e /media/ROM/sbin/init ]; then
-              ROOT_MOUNT_POINT="/media/ROM"
-           fi
-           if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
-              ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
-              if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
-                 mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
-                if [ -f $ROOT_MOUNT_POINT/sbin/init.orig ]; then
-                   rm $ROOT_MOUNT_POINT/sbin/init
-                   rm $ROOT_MOUNT_POINT/sbin/init.altboot
-                   mv $ROOT_MOUNT_POINT/sbin/init.orig $ROOT_MOUNT_POINT/sbin/init
-                else
-                echo "$ROOT_MOUNT_POINT/sbin/init.orig not found, not uninstalling altboot!"
-                fi
-             fi
-           fi
-       fi
-}
diff --git a/packages/altboot/altboot_0.0.0.bb b/packages/altboot/altboot_0.0.0.bb
new file mode 100644 (file)
index 0000000..54d260a
--- /dev/null
@@ -0,0 +1,98 @@
+DESCRIPTION = "A text-based bootmanager allowing a Zaurus to boot from SD, CF, USB-Storage and NFS. \
+Tested machines: Collie, Poodle, Akita, Spitz"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Matthias 'CoreDump' Hentges  <oe@hentges.net>"
+LICENSE = "GPL"
+IGNORE_STRIP_ERRORS = "1"
+
+PR = "r21"
+
+
+SRC_URI = "file://altboot-menu \
+          file://altboot.rc \
+          file://altboot.func \         
+          file://init.altboot \
+          file://altboot*.cfg"
+
+# S = "${WORKDIR}/files"
+do_install() {
+       install -d ${D}/sbin
+       install -d ${D}/etc/altboot-menu
+       install -d ${D}/etc/altboot-menu/Advanced
+       install -d ${D}/etc/altboot.rc
+       install -d ${D}/usr/share/doc/altboot
+       
+       install -m 0644 ${WORKDIR}/altboot*.cfg ${D}/etc
+       install -m 0644 ${WORKDIR}/altboot.func ${D}/etc
+#      install -m 0644 ${WORKDIR}/docs/altboot/*.txt ${D}/usr/share/doc/altboot
+       install -m 0755 ${WORKDIR}/init.altboot ${D}/sbin       
+       install -m 0755 ${WORKDIR}/altboot-menu/*-* ${D}/etc/altboot-menu
+       install -m 0755 ${WORKDIR}/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
+       install -m 0755 ${WORKDIR}/altboot.rc/*.sh ${D}/etc/altboot.rc
+       install -m 0644 ${WORKDIR}/altboot.rc/*.txt ${D}/etc/altboot.rc 
+}              
+
+
+
+pkg_postinst() {
+       update-alternatives --install /sbin/init init /sbin/init.altboot 55
+}
+
+pkg_postinst_spitz() {
+       # Note: Spitz support is a royal pain in the ass.
+       #       Since Spitz pivot_roots by default, there is no real way
+       #       a user can install an altboot.ipk into the flash FS.
+       #       So we need to do that manually (*SIGH*)
+
+       # /l/m only exists on the HDD on spitz
+       if test -d /lib/modules
+       then
+          if [ -e /media/realroot/sbin/init ]; then
+             ROOT_MOUNT_POINT="/media/realroot"
+          elif [ -e /media/ROM/sbin/init ]; then
+             ROOT_MOUNT_POINT="/media/ROM"
+          fi
+          if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
+             ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
+             if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
+                mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
+                cp -R /etc/altboot* $ROOT_MOUNT_POINT/etc
+                cp /sbin/init.altboot $ROOT_MOUNT_POINT/sbin
+                if [ -f $ROOT_MOUNT_POINT/sbin/init ]; then
+                        mv $ROOT_MOUNT_POINT/sbin/init $ROOT_MOUNT_POINT/sbin/init.orig
+                fi
+                ln -s /sbin/init.altboot $ROOT_MOUNT_POINT/sbin/init
+             fi
+          fi
+       fi
+}
+
+pkg_postrm() {
+       update-alternatives --remove init /sbin/init.altboot
+}
+
+pkg_postrm_spitz() {
+       if test -d /lib/modules
+        then
+           if [ -e /media/realroot/sbin/init ]; then
+              ROOT_MOUNT_POINT="/media/realroot"
+           elif [ -e /media/ROM/sbin/init ]; then
+              ROOT_MOUNT_POINT="/media/ROM"
+           fi
+           if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
+              ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
+              if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
+                 mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
+                if [ -f $ROOT_MOUNT_POINT/sbin/init.orig ]; then
+                   rm $ROOT_MOUNT_POINT/sbin/init
+                   rm $ROOT_MOUNT_POINT/sbin/init.altboot
+                   mv $ROOT_MOUNT_POINT/sbin/init.orig $ROOT_MOUNT_POINT/sbin/init
+                else
+                echo "$ROOT_MOUNT_POINT/sbin/init.orig not found, not uninstalling altboot!"
+                fi
+             fi
+           fi
+       fi
+}
diff --git a/packages/altboot/altboot_0.0.5-rc2.bb b/packages/altboot/altboot_0.0.5-rc2.bb
new file mode 100644 (file)
index 0000000..e4e20b5
--- /dev/null
@@ -0,0 +1,123 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: altboot_0.0.5-rc2.bb
+# Date: 21-Feb-06
+
+DESCRIPTION = "The altboot bootmanager"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
+
+######################################################################################
+
+PR = "r0"
+
+######################################################################################
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+SRC_URI = "cvs://anonymous@hentges.net/hentgescvs;method=pserver;tag=${TAG};module=altboot"
+
+######################################################################################
+
+do_install() {
+       install -d ${D}/sbin
+       install -d ${D}/etc/altboot-menu
+       install -d ${D}/etc/altboot-menu/Advanced
+       install -d ${D}/etc/altboot.rc
+       install -d ${D}/usr/share/doc/altboot
+       
+       if test -d ${WORKDIR}/altboot/${MACHINE}
+       then
+               install -m 0644 ${WORKDIR}/altboot/${MACHINE}/altboot*.cfg ${D}/etc
+       else
+               install -m 0644 ${WORKDIR}/altboot/altboot*.cfg ${D}/etc
+       fi
+       
+       install -m 0644 ${WORKDIR}/altboot/altboot.func ${D}/etc
+       install -m 0755 ${WORKDIR}/altboot/init.altboot ${D}/sbin
+       
+       if test -d ${WORKDIR}/altboot/${MACHINE}/altboot-menu/  
+       then
+               install -m 0755 ${WORKDIR}/altboot/${MACHINE}/altboot-menu/*-* ${D}/etc/altboot-menu
+       else
+               install -m 0755 ${WORKDIR}/altboot/altboot-menu/*-* ${D}/etc/altboot-menu
+       fi
+
+       if test -d ${WORKDIR}/altboot/${MACHINE}/altboot-menu/Advanced/
+       then
+               install -m 0755 ${WORKDIR}/altboot/${MACHINE}/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
+       else
+               install -m 0755 ${WORKDIR}/altboot/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
+       fi
+       
+       install -m 0755 ${WORKDIR}/altboot/altboot.rc/*.sh ${D}/etc/altboot.rc
+       install -m 0644 ${WORKDIR}/altboot/altboot.rc/*.txt ${D}/etc/altboot.rc 
+}              
+
+pkg_postinst() {
+       update-alternatives --install /sbin/init init /sbin/init.altboot 55
+}
+
+pkg_postinst_spitz() {
+       # Note: Spitz support is a royal pain in the ass.
+       #       Since Spitz pivot_roots by default, there is no real way
+       #       a user can install an altboot.ipk into the flash FS.
+       #       So we need to do that manually (*SIGH*)
+
+       # /l/m only exists on the HDD on spitz
+       if test -d /lib/modules
+       then
+          if [ -e /media/realroot/sbin/init ]; then
+             ROOT_MOUNT_POINT="/media/realroot"
+          elif [ -e /media/ROM/sbin/init ]; then
+             ROOT_MOUNT_POINT="/media/ROM"
+          fi
+          if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
+             ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
+             if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
+                mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
+                cp -R /etc/altboot* $ROOT_MOUNT_POINT/etc
+                cp /sbin/init.altboot $ROOT_MOUNT_POINT/sbin
+                if [ -f $ROOT_MOUNT_POINT/sbin/init ]; then
+                        mv $ROOT_MOUNT_POINT/sbin/init $ROOT_MOUNT_POINT/sbin/init.orig
+                fi
+                ln -s /sbin/init.altboot $ROOT_MOUNT_POINT/sbin/init
+             fi
+          fi
+       fi
+}
+
+pkg_postrm() {
+       update-alternatives --remove init /sbin/init.altboot
+}
+
+pkg_postrm_spitz() {
+       if test -d /lib/modules
+        then
+           if [ -e /media/realroot/sbin/init ]; then
+              ROOT_MOUNT_POINT="/media/realroot"
+           elif [ -e /media/ROM/sbin/init ]; then
+              ROOT_MOUNT_POINT="/media/ROM"
+           fi
+           if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
+              ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
+              if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
+                 mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
+                if [ -f $ROOT_MOUNT_POINT/sbin/init.orig ]; then
+                   rm $ROOT_MOUNT_POINT/sbin/init
+                   rm $ROOT_MOUNT_POINT/sbin/init.altboot
+                   mv $ROOT_MOUNT_POINT/sbin/init.orig $ROOT_MOUNT_POINT/sbin/init
+                else
+                echo "$ROOT_MOUNT_POINT/sbin/init.orig not found, not uninstalling altboot!"
+                fi
+             fi
+           fi
+       fi
+}
+
+
+
+
index 42f0968..69f7c83 100644 (file)
@@ -18,6 +18,9 @@ USB_STORAGE_MODULES="usb_ohci_pxa27x usb-storage"
 USB_STORAGE_PARTITION="/dev/sda1"
 USB_STORAGE_WAIT="4"
 
+KEXEC_KERNEL_DIR="/boot"
+KEXEC_BIN="/usr/sbin/kexec"
+
 INIT_RUNLEVEL="5"
 NO_GUI_RL="2"
 MASTER_PASSWORD=""
index 9eebeb8..cd6ce7a 100644 (file)
@@ -4,4 +4,5 @@ inherit native
 # A native antlr would need a native java virtual machine..
 # eww. -CL
 DEPENDS = "virtual/java-native"
+RDEPENDS= "virtual/java-native"
 BROKEN = "1"
index 846a447..21a2002 100644 (file)
@@ -1,6 +1,9 @@
 SECTION = "devel"
 include autoconf_${PV}.bb
 DEPENDS = "m4-native gnu-config-native"
+RDEPENDS_${PN} = "m4-native gnu-config-native"
+RRECOMMENDS_${PN} = "automake-native"
+
 S = "${WORKDIR}/autoconf-${PV}"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/autoconf-${PV}"
 
index 172752f..e6d8a41 100644 (file)
@@ -1,6 +1,7 @@
 SECTION = "devel"
 include automake_${PV}.bb
 DEPENDS = "autoconf-native"
+RDEPENDS_${PN} = "autoconf-native perl-native"
 
 inherit native
 
index 7969426..6732f23 100644 (file)
@@ -2,6 +2,7 @@ SECTION = "devel"
 include automake_${PV}.bb
 S = "${WORKDIR}/automake-${PV}"
 DEPENDS = "autoconf-native"
+RDEPENDS_${PN} = "autoconf-native perl-native"
 
 inherit native
 
index 7969426..6732f23 100644 (file)
@@ -2,6 +2,7 @@ SECTION = "devel"
 include automake_${PV}.bb
 S = "${WORKDIR}/automake-${PV}"
 DEPENDS = "autoconf-native"
+RDEPENDS_${PN} = "autoconf-native perl-native"
 
 inherit native
 
index d8405c0..619361b 100644 (file)
@@ -7,7 +7,7 @@ PR = "r7"
 inherit autotools
 
 FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf perl"
+RDEPENDS_${PN} += "autoconf-native perl-native"
 
 do_install () {
        oe_runmake 'DESTDIR=${D}' install
index 5dabcff..ba58f9d 100644 (file)
@@ -2,6 +2,8 @@ include quilt.inc
 
 INHIBIT_AUTOTOOLS_DEPS = "1"
 
+RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native"
+
 SRC_URI = "cvs://anoncvs:@savannah.nongnu.org/cvsroot/quilt;method=ext;rsh=ssh;module=quilt;tag=VER_${@(bb.data.getVar('PV', d, 1) or '').replace('.', '_')} \
           file://install.patch;patch=1 \
           file://nostrip.patch;patch=1 \
index ad3834e..19b4a3b 100644 (file)
@@ -2,6 +2,8 @@ include quilt.inc
 
 INHIBIT_AUTOTOOLS_DEPS = "1"
 
+RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native"
+
 SRC_URI = "cvs://anonymous@cvs.savannah.nongnu.org/cvsroot/quilt;method=pserver;module=quilt;tag=VER_${@(bb.data.getVar('PV', d, 1) or '').replace('.', '_')} \
           file://install.patch;patch=1 \
           file://nostrip.patch;patch=1 \
index cd2d65f..2513a43 100644 (file)
@@ -19,7 +19,7 @@ S = "${WORKDIR}/tslib"
 LICENSE = "LGPL"
 CONFFILES_${PN} = "${sysconfdir}/ts.conf"
 
-inherit autotools
+inherit autotools pkgconfig
 
 PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate"
 EXTRA_OECONF        = "--enable-shared"