different packages: add support for Dreambox DM500+
authorFelix Domke <tmbinc@elitedvb.ne>
Thu, 14 Jun 2007 17:25:55 +0000 (17:25 +0000)
committerFelix Domke <tmbinc@elitedvb.ne>
Thu, 14 Jun 2007 17:25:55 +0000 (17:25 +0000)
23 files changed:
conf/machine/dm500plus.conf [new file with mode: 0644]
packages/base-files/base-files/dm500plus/.mtn2git_empty [new file with mode: 0644]
packages/base-files/base-files/dm500plus/fstab [new file with mode: 0644]
packages/dreambox/dreambox-bootlogo.bb
packages/dreambox/dreambox-dvb-modules.bb
packages/dreambox/dreambox-dvbincludes.bb
packages/dreambox/dreambox-secondstage.bb
packages/enigma/enigma_cvs.bb
packages/images/dreambox-image.bb
packages/initscripts/initscripts-1.0/dm500plus/.mtn2git_empty [new file with mode: 0644]
packages/initscripts/initscripts-1.0/dm500plus/bootup [new file with mode: 0644]
packages/initscripts/initscripts-opendreambox_1.0.bb
packages/ipkg/ipkg-collateral/dm500plus/.mtn2git_empty [new file with mode: 0644]
packages/ipkg/ipkg-collateral/dm500plus/dest [new file with mode: 0644]
packages/linux/linux-dm500plus.bb [new file with mode: 0644]
packages/linux/linux-dm600pvr.bb
packages/netbase/netbase/dm500plus/.mtn2git_empty [new file with mode: 0644]
packages/netbase/netbase/dm500plus/interfaces [new file with mode: 0644]
packages/ppp/ppp_2.4.3.bb
packages/sysvinit/sysvinit/dm500plus/.mtn2git_empty [new file with mode: 0644]
packages/sysvinit/sysvinit/dm500plus/inittab [new file with mode: 0644]
packages/tuxbox/tuxbox-libtuxtxt.bb
packages/tuxbox/tuxbox-plugins.bb

diff --git a/conf/machine/dm500plus.conf b/conf/machine/dm500plus.conf
new file mode 100644 (file)
index 0000000..88ef3d5
--- /dev/null
@@ -0,0 +1,46 @@
+TARGET_ARCH = "powerpc"
+IPKG_ARCHS = "all powerpc ${MACHINE}"
+PREFERRED_PROVIDER_xserver = "xserver-kdrive"
+PREFERRED_PROVIDER_virtual/kernel = "linux-dm500plus"
+BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel dreambox-dvb-modules"
+BOOTSTRAP_EXTRA_RDEPENDS = "kernel dreambox-dvb-modules"
+
+TARGET_FPU = "soft"
+TARGET_CPU = "405"
+
+OVERRIDES =. "dvbapiv1:"
+
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}libc-for-gcc:glibc"
+
+PREFERRED_VERSION_glibc = "2.3.5+cvs20050627"
+PREFERRED_VERSION_glibc-initial = "2.3.2+cvs20040726"
+PREFERRED_VERSION_gcc-cross-initial = "3.4.4"
+PREFERRED_VERSION_gcc-cross = "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk = "3.4.4" 
+PREFERRED_VERSION_gcc = "3.4.4"
+PREFERRED_VERSION_gdb = "6.5"
+PREFERRED_VERSION_gdb-cross = "6.5"
+PREFERRED_VERSION_binutils-cross = "2.15.94.0.1"
+PREFERRED_VERSION_binutils-cross-sdk = "2.15.94.0.1"
+PREFERRED_VERSION_binutils = "2.15.94.0.1"
+PREFERRED_VERSION_busybox = "1.01"
+
+GLIBC_ADDONS = "nptl"
+GLIBC_EXTRA_OECONF = "--with-tls --without-fp --with-__thread"
+
+EXTRA_IMAGEDEPENDS += "dreambox-secondstage dreambox-buildimage-native"
+EXTRA_IMAGECMD_jffs2 = " --eraseblock=0x4000 -n -b "
+IMAGE_CMD_jffs2 = "mkfs.jffs2 --root=${IMAGE_ROOTFS}/boot --faketime \
+       --output=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.boot.jffs2 \
+       ${EXTRA_IMAGECMD}; rm -rf ${IMAGE_ROOTFS}/boot/*; \
+                               mkfs.jffs2 --root=${IMAGE_ROOTFS} --faketime \
+       --output=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
+       ${EXTRA_IMAGECMD}; \
+       buildimage ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz \
+       ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.boot.jffs2 \
+       ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
+       ${MACHINE} \
+       > ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.nfi"
diff --git a/packages/base-files/base-files/dm500plus/.mtn2git_empty b/packages/base-files/base-files/dm500plus/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/base-files/base-files/dm500plus/fstab b/packages/base-files/base-files/dm500plus/fstab
new file mode 100644 (file)
index 0000000..9031cdb
--- /dev/null
@@ -0,0 +1,7 @@
+rootfs               /                    auto       defaults              1 1
+proc                 /proc                proc       defaults              0 0
+devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
+usbdevfs             /proc/bus/usb        usbdevfs   defaults              0 0
+/dev/mtdblock/2      /boot                jffs2      ro                    0 0
+tmpfs                /var                 tmpfs      defaults              0 0
+tmpfs                /tmp                 tmpfs      defaults              0 0
index 13296c4..a40c017 100644 (file)
@@ -7,18 +7,10 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 PV = "1.0"
 PR = "r1"
 
-SRC_URI = "http://sources.dreamboxupdate.com/download/7020/bootlogo_dm600pvr.elf \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_dm7020.elf \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_dm7025.elf \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_dm7020.mvi \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_wait_dm7020.mvi \
-       http://sources.dreamboxupdate.com/download/7020/backdrop_dm7020.mvi \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_dm7025.mvi \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_wait_dm7025.mvi \
-       http://sources.dreamboxupdate.com/download/7020/backdrop_dm7025.mvi \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_dm600pvr.mvi \
-       http://sources.dreamboxupdate.com/download/7020/bootlogo_wait_dm600pvr.mvi \
-       http://sources.dreamboxupdate.com/download/7020/backdrop_dm600pvr.mvi"
+SRC_URI = "http://sources.dreamboxupdate.com/download/7020/bootlogo_${MACHINE}.elf \
+       http://sources.dreamboxupdate.com/download/7020/bootlogo_${MACHINE}.mvi \
+       http://sources.dreamboxupdate.com/download/7020/bootlogo_wait_${MACHINE}.mvi \
+       http://sources.dreamboxupdate.com/download/7020/backdrop_${MACHINE}.mvi"
 
 S = "${WORKDIR}/"
 
index 0e7713c..50627d1 100644 (file)
@@ -18,6 +18,9 @@ PV_dm7025 = "${KV}-20070420${@get_modules_extension(bb, d)}"
 KV_dm600pvr = "2.6.12"
 PV_dm600pvr = "${KV}-20070403"
 
+KV_dm500plus = "2.6.12"
+PV_dm500plus = "${KV}-20070614"
+
 RDEPENDS = "kernel (${KV})"
 PR = "r0"
 
@@ -40,6 +43,13 @@ do_install_dm7020() {
        done
 }
 
+do_install_dm500plus() {
+       install -d ${D}/lib/modules/${KV}/extra
+       for f in head; do
+               install -m 0644 $f.ko ${D}/lib/modules/${KV}/extra/$f.ko;
+       done
+}
+
 do_install_dm7025() {
        install -d ${D}/lib/modules/${KV}/extra
        for f in alps_bsbe1.ko avs.ko cu1216mk3.ko dreambox_rc2.ko \
index 5c6f3f4..2569249 100644 (file)
@@ -43,6 +43,17 @@ do_install_dm600pvr() {
        done;
 }
 
+do_install_dm500plus() {
+       install -d ${STAGING_INCDIR}/ci
+       install -d ${STAGING_INCDIR}/dbox
+       install -d ${STAGING_INCDIR}/dreambox
+       install -d ${STAGING_INCDIR}/ost
+       install -d ${STAGING_INCDIR}/tuxbox
+       for f in ${INPUT_FILES} ${INPUT_FILES_OST}; do
+               install -m 0644 ${S}/$f ${STAGING_INCDIR}/$f
+       done;
+}
+
 do_install_dm7025() {
        install -d ${STAGING_INCDIR}/ci
        install -d ${STAGING_INCDIR}/dbox
index 1b9bb18..6c51c72 100644 (file)
@@ -5,6 +5,7 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 PV_dm7020 = "35"
 PV_dm7025 = "51"
 PV_dm600pvr = "51"
+PV_dm500plus = "52"
 PR = "r0"
 
 SRC_URI = "http://sources.dreamboxupdate.com/download/7020/secondstage-${MACHINE}-${PV}.bin"
index 9f3ed10..e0ae69c 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Enigma is a framebuffer-based frontend for DVB functions"
 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 LICENSE = "GPL"
 
-SRCDATE = "20070327"
+SRCDATE = "20070615"
 PV = "cvs-${SRCDATE}"
 PN = "enigma"
 PR = "r0"
@@ -18,7 +18,9 @@ SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/tuxbox/enigma;met
            file://rotor_fix.diff;patch=1;pnum=1 \
            file://disable_boot.diff;patch=1;pnum=1"
 
+# dm600pvr and dm500plus don't have a FP, so they can't really switch of. Show a shutdown pic instead.
 SRC_URI_append_dm600pvr = " http://sources.dreamboxupdate.com/download/opendreambox/enigma/showshutdownpic-${MACHINE}"
+SRC_URI_append_dm500plus = " http://sources.dreamboxupdate.com/download/opendreambox/enigma/showshutdownpic-${MACHINE}"
 
 S = "${WORKDIR}/enigma"
 
@@ -57,8 +59,8 @@ do_install_append() {
        mv ${D}/etc/enigma/* ${D}/usr/share/enigma/default 2> /dev/null || /bin/true
        rm -R ${D}/etc/enigma 2> /dev/null || /bin/true
        install -m 0644 ${WORKDIR}/config ${D}/usr/share/enigma/default/
-       if [ "${MACHINE}" = "dm600pvr" ]; then
-               install -m 0755 ${WORKDIR}/showshutdownpic-dm600pvr ${D}/usr/bin/showshutdownpic
+       if [ "${MACHINE}" = "dm600pvr" -o "${MACHINE}" = "dm500plus" ]; then
+               install -m 0755 ${WORKDIR}/showshutdownpic-${MACHINE} ${D}/usr/bin/showshutdownpic
                # vulcan-based boxes don't look that well with too much alpha
                echo "i:/ezap/osd/alpha=00000000" >> ${D}/usr/share/enigma/default/config
                echo "i:/ezap/osd/simpleMainMenu=00000001" >> ${D}/usr/share/enigma/default/config
index d2a54ce..811d7f9 100644 (file)
@@ -50,6 +50,14 @@ OPENDREAMBOX_TUXBOX_R_dm600pvr = " \
        tuxbox-plugin-tank      tuxbox-plugin-pacman    tuxbox-plugin-tetris \
        tuxbox-plugin-tuxcom    links-dream-plugin"
 
+OPENDREAMBOX_TUXBOX_R_dm500plus = " \
+       tuxbox-plugin-snake     tuxbox-plugin-tuxmail \
+       tuxbox-plugin-soko      tuxbox-plugin-tuxtxt \
+       tuxbox-plugin-sol       tuxbox-plugin-vierg     tuxbox-plugin-master \
+       tuxbox-plugin-solitair  tuxbox-plugin-yahtzee   tuxbox-plugin-mines  \
+       tuxbox-plugin-tank      tuxbox-plugin-pacman    tuxbox-plugin-tetris \
+       tuxbox-plugin-tuxcom    links-dream-plugin"
+
 # dvb api specific stuff
 OPENDREAMBOX_V2_ONLY = "dreambox-dvb-tools tuxbox-stream"
 OPENDREAMBOX_V3_ONLY = "dreambox-dvb-tools-v3 sctzap dvbtraffic"
@@ -66,6 +74,7 @@ ENIGMA_LANGUAGE = "enigma-locale-cs enigma-locale-da \
 
 OPENDREAMBOX_TUXBOX_R += " ${ENIGMA_LANGUAGE}"
 OPENDREAMBOX_TUXBOX_R_dm600pvr += " ${ENIGMA_LANGUAGE}"
+OPENDREAMBOX_TUXBOX_R_dm500plus += " ${ENIGMA_LANGUAGE}"
 
 MODEM_SUPPORT = "enigma-modem"
 MODEM_SUPPORT_R = "kernel-module-crc-ccitt kernel-module-ppp-async \
@@ -77,6 +86,10 @@ OPENDREAMBOX_COMMON_MACHINE_dm600pvr += "${OPENDREAMBOX_V2_ONLY} ${OPENDREAMBOX_
 OPENDREAMBOX_COMMON_MACHINE_R_dm600pvr += "${OPENDREAMBOX_TUXBOX_R} ${MODEM_SUPPORT_R}"
 OPENDREAMBOX_COMMON_MACHINE_D_dm600pvr += "${OPENDREAMBOX_TUXBOX_D}"
 
+OPENDREAMBOX_COMMON_MACHINE_dm500plus += "${OPENDREAMBOX_V2_ONLY} ${OPENDREAMBOX_TUXBOX} ${MODEM_SUPPORT}"
+OPENDREAMBOX_COMMON_MACHINE_R_dm500plus += "${OPENDREAMBOX_TUXBOX_R} ${MODEM_SUPPORT_R}"
+OPENDREAMBOX_COMMON_MACHINE_D_dm500plus += "${OPENDREAMBOX_TUXBOX_D}"
+
 OPENDREAMBOX_COMMON_MACHINE_dm7020 += "${OPENDREAMBOX_V2_ONLY} ${OPENDREAMBOX_TUXBOX} ${MODEM_SUPPORT}"
 OPENDREAMBOX_COMMON_MACHINE_R_dm7020 += "${OPENDREAMBOX_TUXBOX_R} ${MODEM_SUPPORT_R}"
 OPENDREAMBOX_COMMON_MACHINE_D_dm7020 += "${OPENDREAMBOX_TUXBOX_D}"
diff --git a/packages/initscripts/initscripts-1.0/dm500plus/.mtn2git_empty b/packages/initscripts/initscripts-1.0/dm500plus/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/initscripts/initscripts-1.0/dm500plus/bootup b/packages/initscripts/initscripts-1.0/dm500plus/bootup
new file mode 100644 (file)
index 0000000..d40bfb5
--- /dev/null
@@ -0,0 +1,19 @@
+modprobe lcd
+mount -t proc proc /proc
+mount -t sysfs sysfs /sys
+depmod -Ae
+swapon -a
+mount -at nonfs,nosmbfs,noncpfs 2>/dev/null
+tar xzf /etc/var.tar.gz -C /
+modprobe head
+modprobe dreambox_keyboard
+[ -e /etc/dropbear/dropbear_rsa_host_key ] && /usr/bin/showiframe /boot/bootlogo.mvi || /usr/bin/showiframe /boot/bootlogo_wait.mvi
+hostname -F /etc/hostname
+/usr/bin/wdog /usr/bin/dccamd -
+ifup -a
+mount -at nfs,smbfs,cpfs 2>/dev/null
+[ -e "/etc/sysctl.conf" ] && /sbin/sysctl -p "/etc/sysctl.conf"
+ldconfig
+ln -s demux0 /dev/dvb/card0/demux1
+ln -s dvr0 /dev/dvb/card0/dvr1
+ln -s fb/0 /dev/fb0
index 4ccd541..46998e5 100644 (file)
@@ -48,7 +48,7 @@ do_install () {
 #
 # Install device dependent scripts
 #
-       if [ "${MACHINE}" = "dm600pvr" ]; then
+       if [ "${MACHINE}" = "dm600pvr" -o "${MACHINE}" = "dm500plus" ]; then
                head -n 4 ${WORKDIR}/umountfs > ${D}${sysconfdir}/init.d/umountfs
                echo "cd /tmp" >> ${D}${sysconfdir}/init.d/umountfs
                tail -n 14 ${WORKDIR}/umountfs >> ${D}${sysconfdir}/init.d/umountfs
diff --git a/packages/ipkg/ipkg-collateral/dm500plus/.mtn2git_empty b/packages/ipkg/ipkg-collateral/dm500plus/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/ipkg/ipkg-collateral/dm500plus/dest b/packages/ipkg/ipkg-collateral/dm500plus/dest
new file mode 100644 (file)
index 0000000..17d457f
--- /dev/null
@@ -0,0 +1,3 @@
+dest root /
+dest cf /media/cf/
+dest ram /media/ram/
diff --git a/packages/linux/linux-dm500plus.bb b/packages/linux/linux-dm500plus.bb
new file mode 100644 (file)
index 0000000..8f5c713
--- /dev/null
@@ -0,0 +1,41 @@
+DESCRIPTION = "Linux kernel for Dreambox DM500PLUS"
+LICENSE = "GPL"
+PN = "linux-dm500plus"
+PV = "2.6.12"
+PR = "r0"
+
+# -rX is the patch revision - it's not related to this package's PR
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.bz2 \
+       http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dream-ppc-r4.patch.gz;patch=1;pnum=1"
+
+S = "${WORKDIR}/linux-2.6.12"
+
+inherit kernel
+
+FILES_kernel-image = "/boot/zImage.elf /boot/autoexec.bat"
+
+export OS = "Linux"
+ARCH = "ppc"
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
+
+do_configure_prepend() {
+       oe_machinstall -m 0644 ${S}/arch/ppc/configs/dm500plus_defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
+       oe_runmake oldconfig
+}
+
+do_install_append () {
+       install -d ${D}/boot
+       install -m 0755 arch/ppc/boot/images/zImage.elf ${D}/boot/zImage.elf
+       echo "/flash/bootlogo.elf" > ${D}/boot/autoexec.bat
+       echo "/flash/zImage.elf" >> ${D}/boot/autoexec.bat
+}
+
+pkg_postinst_kernel () {
+       true
+}
+
+pkg_postrm_kernel () {
+       true
+}
+
index 44351c3..69d6ae8 100644 (file)
@@ -6,7 +6,7 @@ PR = "r3"
 
 # -rX is the patch revision - it's not related to this package's PR
 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.bz2 \
-       http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dm600pvr-r3.patch.gz;patch=1;pnum=1"
+       http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dream-ppc-r4.patch.gz;patch=1;pnum=1"
 
 S = "${WORKDIR}/linux-2.6.12"
 
diff --git a/packages/netbase/netbase/dm500plus/.mtn2git_empty b/packages/netbase/netbase/dm500plus/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/netbase/netbase/dm500plus/interfaces b/packages/netbase/netbase/dm500plus/interfaces
new file mode 100644 (file)
index 0000000..673618f
--- /dev/null
@@ -0,0 +1,10 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Ethernet
+auto eth0
+iface eth0 inet dhcp
+
index 6ffad29..602627f 100644 (file)
@@ -40,7 +40,7 @@ do_install_append () {
        install -m 0755 ${WORKDIR}/08setupdns ${D}${sysconfdir}/ppp/ip-up.d/
        install -m 0755 ${WORKDIR}/92removedns ${D}${sysconfdir}/ppp/ip-down.d/
        rm -rf ${D}/${mandir}/man8/man8
-       if [ ${MACHINE} = "dm600pvr" -o ${MACHINE} = "dm7020" ]; then
+       if [ ${DISTRO} = "opendreambox" ]; then
                for i in pap-secrets options; do
                        rm ${D}/etc/ppp/$i
                done
@@ -48,8 +48,7 @@ do_install_append () {
 }
 
 CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options"
-CONFFILES_${PN}_dm600pvr = "${sysconfdir}/ppp/chap-secrets"
-CONFFILES_${PN}_dm7020 = "${sysconfdir}/ppp/chap-secrets"
+CONFFILES_${PN}_opendreambox = "${sysconfdir}/ppp/chap-secrets"
 PACKAGES += "ppp-oa ppp-oe ppp-radius ppp-winbind ppp-minconn ppp-password ppp-tools"
 FILES_${PN}        = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd"
 FILES_ppp-oa       = "/usr/lib/pppd/2.4.3/pppoatm.so"
diff --git a/packages/sysvinit/sysvinit/dm500plus/.mtn2git_empty b/packages/sysvinit/sysvinit/dm500plus/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/sysvinit/sysvinit/dm500plus/inittab b/packages/sysvinit/sysvinit/dm500plus/inittab
new file mode 100644 (file)
index 0000000..9a1783a
--- /dev/null
@@ -0,0 +1,32 @@
+# /etc/inittab: init(8) configuration.
+# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $
+
+# The default runlevel.
+id:2:initdefault:
+
+# Boot-time system configuration/initialization script.
+# This is run first except when booting in emergency (-b) mode.
+si::sysinit:/etc/init.d/rcS
+
+# What to do in single-user mode.
+~~:S:wait:/sbin/sulogin
+
+# /etc/init.d executes the S and K scripts upon change
+# of runlevel.
+#
+# Runlevel 0 is halt.
+# Runlevel 1 is single-user.
+# Runlevels 2-5 are multi-user.
+# Runlevel 6 is reboot.
+
+l0:0:wait:/etc/init.d/rc 0
+l1:1:wait:/etc/init.d/rc 1
+l2:2:wait:/etc/init.d/rc 2
+l3:3:wait:/etc/init.d/rc 3
+l4:4:wait:/etc/init.d/rc 4
+l5:5:wait:/etc/init.d/rc 5
+l6:6:wait:/etc/init.d/rc 6
+# Normally not reached, but fallthrough in case of emergency.
+z6:6:respawn:/sbin/sulogin
+
+S:5:respawn:/sbin/getty tts/0 115200
index 2bbe32e..8490339 100644 (file)
@@ -7,6 +7,7 @@ SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/tuxbox/libs;metho
 SRC_URI_append_dm7025 = " file://libtuxtxt_bugfix.patch;patch=1"
 
 SRCDATE_dm600pvr = "20070307"
+SRCDATE_dm500plus = "20070307"
 SRCDATE_dm7025 = "20050912"
 SRCDATE_dm7020 = "20070307"
 
index d2c46b3..5e4b9bd 100644 (file)
@@ -14,9 +14,11 @@ PR = "r0"
 CFLAGS_append = " -DOE"
 CFLAGS_append_dm7020 = " -DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"
 CFLAGS_append_dm600pvr = " -DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"
+CFLAGS_append_dm500plus = " -DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"
 CXXFLAGS_append = " -DOE"
 CXXFLAGS_append_dm7020 = " -DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"
 CXXFLAGS_append_dm600pvr = " -DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"
+CXXFLAGS_append_dm500plus = " -DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"
 
 PACKAGES = "tuxbox-plugins-dev tuxbox-plugin-tuxtxt tuxbox-plugin-tuxmail \
        tuxbox-plugin-tuxcom tuxbox-plugin-mines tuxbox-plugin-pacman \
@@ -65,6 +67,7 @@ EXTRA_OECONF = "--with-target=native"
 EXTRA_OECONF_append_dm7020 = " --with-boxtype=dm7020"
 # checkme!
 EXTRA_OECONF_append_dm600pvr = " --with-boxtype=dm7020"
+EXTRA_OECONF_append_dm500plus = " --with-boxtype=dm7020"
 
 do_install_append() {
        install -d ${D}/etc/tuxbox/tuxtxt/