update-alternatives: move to opkg
authorKoen Kooi <koen@openembedded.org>
Wed, 19 Mar 2008 09:42:58 +0000 (09:42 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 19 Mar 2008 09:42:58 +0000 (09:42 +0000)
* u-a source needs to get moved to opkg-svn as well, but I'll leave that to the opkg dudes

packages/update-alternatives/update-alternatives-cworth-native_0.99.154.bb
packages/update-alternatives/update-alternatives-cworth.inc
packages/update-alternatives/update-alternatives-cworth_0.99.154.bb
packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb

index 36f023e..40534b4 100644 (file)
@@ -5,7 +5,7 @@ PROVIDES += "virtual/update-alternatives-native"
 
 do_stage () {
     install -d ${sbindir} \
-               ${libdir}/ipkg/alternatives
+               ${libdir}/opkg/alternatives
 
     install -m 0755 update-alternatives ${sbindir}/update-alternatives
 }
index d2d78c9..f23bfe8 100644 (file)
@@ -3,3 +3,5 @@ SECTION = "base"
 SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')}"
 S = "${WORKDIR}/ipkg/C"
 PACKAGE_ARCH = "all"
+
+PR = "r1"
index 18dab4e..6cab1e5 100644 (file)
@@ -5,7 +5,7 @@ RPROVIDES_${PN} = "update-alternatives"
 do_install () {
     install -d ${D}${sbindir} \
                ${D}${sysconfdir}/alternatives \
-               ${D}${libdir}/ipkg/alternatives
+               ${D}${libdir}/opkg/alternatives
 
     install -m 0755 update-alternatives ${D}${sbindir}/update-alternatives
 }
index 6c193f9..70b5cb7 100644 (file)
@@ -2,7 +2,7 @@ require update-alternatives-dpkg.inc
 inherit native
 
 PROVIDES += "virtual/update-alternatives-native"
-DEPENDS += "perl-native dpkg-native"
+DEPENDS = "perl-native dpkg-native"
 DEFAULT_PREFERENCE = "-1"
 
 do_stage () {