python-lxml: add patch to make it use pkgconfig instead of binconfig to detect its...
authorMichael Lauer <mickey@vanille-media.de>
Mon, 20 Aug 2007 22:45:42 +0000 (22:45 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Mon, 20 Aug 2007 22:45:42 +0000 (22:45 +0000)
packages/python/python-lxml/.mtn2git_empty [new file with mode: 0644]
packages/python/python-lxml/use-pkgconfig-to-detect.patch [new file with mode: 0644]
packages/python/python-lxml_1.3.3.bb

diff --git a/packages/python/python-lxml/.mtn2git_empty b/packages/python/python-lxml/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/python/python-lxml/use-pkgconfig-to-detect.patch b/packages/python/python-lxml/use-pkgconfig-to-detect.patch
new file mode 100644 (file)
index 0000000..b79f1b2
--- /dev/null
@@ -0,0 +1,31 @@
+Index: lxml-1.3.3/setupinfo.py
+===================================================================
+--- lxml-1.3.3.orig/setupinfo.py       2007-08-20 22:39:09.000000000 +0000
++++ lxml-1.3.3/setupinfo.py    2007-08-20 22:39:46.000000000 +0000
+@@ -86,7 +86,7 @@
+         return static_library_dirs
+     # filter them from xslt-config --libs
+     result = []
+-    possible_library_dirs = flags('xslt-config --libs')
++    possible_library_dirs = flags('pkg-config libxslt --libs')
+     for possible_library_dir in possible_library_dirs:
+         if possible_library_dir.startswith('-L'):
+             result.append(possible_library_dir[2:])
+@@ -100,7 +100,7 @@
+         return static_include_dirs
+     # filter them from xslt-config --cflags
+     result = []
+-    possible_include_dirs = flags('xslt-config --cflags')
++    possible_include_dirs = flags('pkg-config libxslt --cflags')
+     for possible_include_dir in possible_include_dirs:
+         if possible_include_dir.startswith('-I'):
+             result.append(possible_include_dir[2:])
+@@ -119,7 +119,7 @@
+         return result
+     # anything from xslt-config --cflags that doesn't start with -I
+-    possible_cflags = flags('xslt-config --cflags')
++    possible_cflags = flags('pkg-config libxslt --cflags')
+     for possible_cflag in possible_cflags:
+         if not possible_cflag.startswith('-I'):
+             result.append(possible_cflag)
index de0566e..7ead15b 100644 (file)
@@ -3,9 +3,10 @@ HOMEPAGE = "http://codespeak.net/lxml/"
 AUTHOR = "http://codespeak.net/mailman/listinfo/lxml-dev"
 LICENSE = "BSD"
 DEPENDS = "libxml2 libxslt"
-PR = "ml0"
+PR = "ml1"
 
-SRC_URI = "http://codespeak.net/lxml/lxml-${PV}.tgz"
+SRC_URI = "http://codespeak.net/lxml/lxml-${PV}.tgz \
+           file://use-pkgconfig-to-detect.patch;patch=1"
 S = "${WORKDIR}/lxml-${PV}"
 
 inherit distutils