gpe-session-scripts: Use update-alternatives for gpe-logout to allow for different...
authorMatthias Hentges <oe@hentges.net>
Wed, 5 Jul 2006 09:04:46 +0000 (09:04 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 5 Jul 2006 09:04:46 +0000 (09:04 +0000)
packages/gpe-session-scripts/gpe-session-scripts_0.67.bb

index 6a373cb..8879833 100644 (file)
@@ -12,6 +12,8 @@ DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal gpe-question
 SRC_URI += "file://matchbox-session \
        file://disable-composite.xsettings"
 
+PR = "r1"
+
 #apply a patch to set the fontsize for bigdpi (200+) devices to 5
 SRC_URI_append_ipaq-pxa270 = " file://highdpifontfix.patch;patch=1"
 SRC_URI_append_spitz = " file://highdpifontfix.patch;patch=1"
@@ -29,6 +31,16 @@ do_install_append() {
 
        install -d ${D}${sysconfdir}/gpe/xsettings-default.d
        install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
+       
+       mv ${D}/usr/bin/gpe-logout ${D}/usr/bin/gpe-logout.matchbox
+}
+
+pkg_postinst_${PN}() { 
+       update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.matchbox 10
+}
+
+pkg_postrm_${PN}() {   
+       update-alternatives --remove gpe-logout /usr/bin/gpe-logout.matchbox 
 }
 
 # This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately