merge of 40e0d43922ade23991fd310c42765e18cb590337
authorFlorian Boor <florian.boor@kernelconcepts.de>
Tue, 25 Apr 2006 20:16:57 +0000 (20:16 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 25 Apr 2006 20:16:57 +0000 (20:16 +0000)
     and 58d737a9422a93415e99e0ad16e64549264b4bb2

1  2 
classes/palmtop.bbclass
packages/python/python_2.4.3.bb

@@@ -1,20 -1,17 +1,10 @@@
--# this build class sets up qmake variables to
--#   * build using the Qt Windowing System (QWS)
--#   * use qt
--#   * link against supc++ instead of stdc++  
--#   * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
--# inherit this class to build programs against libqpe
--# inherit opie if you want to build programs against libopie2
--# don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
++# basically a placeholder for something more fancy
++# for now, just declare some things
  
  inherit qmake
  
- # special case for DISTRO = sharprom
- CPP_SUPPORT_LIB = "LIBS-=-lstdc++ LIBS+=-lsupc++"
- CPP_SUPPORT_LIB_sharprom = "LIBS-=-lstdc++"
- EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt ${CPP_SUPPORT_LIB}"
 -EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
--EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "CONFIG-=thread",d)}'
--EXTRA_QMAKEVARS_POST += "${@["LIBS+=-lqpe ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
--DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
++EXTRA_QMAKEVARS_POST_append = " DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
++
++DEPENDS_prepend = "virtual/libqpe uicmoc-native "
  
  FILES_${PN} = "${palmtopdir}"
@@@ -5,8 -5,7 +5,7 @@@ SECTION = "devel/python
  PRIORITY = "optional"
  MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
  DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
- DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
- PR = "ml2"
 -PR = "ml1"
++PR = "ml0"
  
  PYTHON_MAJMIN = "2.4"
  
@@@ -63,7 -62,6 +62,6 @@@ do_install() 
  
  include python-${PV}-manifest.inc
  
--RPROVIDES_python-core = "python"
- RPROVIDES_python-curses = "python"
  PACKAGES =+ "libpython2"
  FILES_libpython2 = "${libdir}/libpython*"
++