classpath: fix config.rpath, autotools and ecj -d
authorHenning Heinold <heinold@inf.fu-berlin.de>
Tue, 26 Aug 2008 09:37:51 +0000 (09:37 +0000)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Tue, 26 Aug 2008 09:37:51 +0000 (09:37 +0000)
* add ecj_java_dir.patch for issuse when ecj is not cable to
  to create directory-structure with parameter -d
* add autotools.patch for m4 stuff
* copy config.rpath always from /usr/share/gettext, so no crude hacks are
  needed anymore
* bump PR on all recipes

18 files changed:
packages/classpath/classpath-0.97.2/.mtn2git_empty [new file with mode: 0644]
packages/classpath/classpath-0.97.2/autotools.patch [new file with mode: 0644]
packages/classpath/classpath-initial_0.93.bb
packages/classpath/classpath-minimal-0.97.2/.mtn2git_empty [new file with mode: 0644]
packages/classpath/classpath-minimal-0.97.2/autotools.patch [new file with mode: 0644]
packages/classpath/classpath-minimal_0.96.1.bb
packages/classpath/classpath-minimal_0.97.2.bb
packages/classpath/classpath-native-0.97.2/.mtn2git_empty [new file with mode: 0644]
packages/classpath/classpath-native-0.97.2/autotools.patch [new file with mode: 0644]
packages/classpath/classpath-native.inc
packages/classpath/classpath-native_0.96.1.bb
packages/classpath/classpath-native_0.97.2.bb
packages/classpath/classpath.inc
packages/classpath/classpath_0.95.bb
packages/classpath/classpath_0.96.1.bb
packages/classpath/classpath_0.97.2.bb
packages/classpath/files/autotools.patch [new file with mode: 0644]
packages/classpath/files/ecj_java_dir.patch [new file with mode: 0644]

diff --git a/packages/classpath/classpath-0.97.2/.mtn2git_empty b/packages/classpath/classpath-0.97.2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/classpath/classpath-0.97.2/autotools.patch b/packages/classpath/classpath-0.97.2/autotools.patch
new file mode 100644 (file)
index 0000000..3df65cf
--- /dev/null
@@ -0,0 +1,26 @@
+Index: classpath-0.97.2/configure.ac
+===================================================================
+--- classpath-0.97.2.orig/configure.ac 2008-06-06 02:58:57.000000000 +0200
++++ classpath-0.97.2/configure.ac      2008-08-02 00:58:16.537364104 +0200
+@@ -41,6 +41,8 @@
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local/classpath)
++AC_CONFIG_MACRO_DIR([m4])
++
+ dnl -----------------------------------------------------------
+ dnl Enable collections.jar (disabled by default)
+ dnl -----------------------------------------------------------
+Index: classpath-0.97.2/Makefile.am
+===================================================================
+--- classpath-0.97.2.orig/Makefile.am  2008-06-01 20:47:05.000000000 +0200
++++ classpath-0.97.2/Makefile.am       2008-08-02 00:58:39.004023720 +0200
+@@ -5,7 +5,7 @@
+ DIST_SUBDIRS = lib doc external include native resource scripts tools examples
+ # Allow users to pass site-specific flags to autoreconf via an env var. 
+-ACLOCAL_AMFLAGS = -I m4 ${LOCAL_AUTORECONF_FLAGS}
++ACLOCAL_AMFLAGS = -I m4 --install ${LOCAL_AUTORECONF_FLAGS}
+ native: lib
index 7c1b91e..59a36b6 100644 (file)
@@ -5,9 +5,11 @@ require classpath-native.inc
 
 DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
 
-PR = "r2"
+PR = "r3"
 
-DEPENDS = "zip-native fastjar-native jikes-native"
+DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
+
+SRC_URI += "file://autotools.patch;patch=1"
 
 EXTRA_OECONF = "\
   --with-jikes=jikes \
diff --git a/packages/classpath/classpath-minimal-0.97.2/.mtn2git_empty b/packages/classpath/classpath-minimal-0.97.2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/classpath/classpath-minimal-0.97.2/autotools.patch b/packages/classpath/classpath-minimal-0.97.2/autotools.patch
new file mode 100644 (file)
index 0000000..3df65cf
--- /dev/null
@@ -0,0 +1,26 @@
+Index: classpath-0.97.2/configure.ac
+===================================================================
+--- classpath-0.97.2.orig/configure.ac 2008-06-06 02:58:57.000000000 +0200
++++ classpath-0.97.2/configure.ac      2008-08-02 00:58:16.537364104 +0200
+@@ -41,6 +41,8 @@
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local/classpath)
++AC_CONFIG_MACRO_DIR([m4])
++
+ dnl -----------------------------------------------------------
+ dnl Enable collections.jar (disabled by default)
+ dnl -----------------------------------------------------------
+Index: classpath-0.97.2/Makefile.am
+===================================================================
+--- classpath-0.97.2.orig/Makefile.am  2008-06-01 20:47:05.000000000 +0200
++++ classpath-0.97.2/Makefile.am       2008-08-02 00:58:39.004023720 +0200
+@@ -5,7 +5,7 @@
+ DIST_SUBDIRS = lib doc external include native resource scripts tools examples
+ # Allow users to pass site-specific flags to autoreconf via an env var. 
+-ACLOCAL_AMFLAGS = -I m4 ${LOCAL_AUTORECONF_FLAGS}
++ACLOCAL_AMFLAGS = -I m4 --install ${LOCAL_AUTORECONF_FLAGS}
+ native: lib
index 826c5a9..94f8dec 100644 (file)
@@ -1,6 +1,6 @@
 require classpath.inc
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI += "\
   file://gjar-prefix-patch.diff;patch=1;pnum=0 \
index e45ddf3..5e6d532 100644 (file)
@@ -4,9 +4,11 @@ SRC_URI += "\
   file://netif_16.patch;patch=1;pnum=0 \
   file://SimpleName.diff;patch=1;pnum=0 \
   file://javanet-local.patch;patch=1;pnum=0 \
+  file://ecj_java_dir.patch;patch=1 \
+  file://autotools.patch;patch=1 \
   "
 
-PR = "r0"
+PR = "r1"
 
 PROVIDES = "${PN} classpath"
 
diff --git a/packages/classpath/classpath-native-0.97.2/.mtn2git_empty b/packages/classpath/classpath-native-0.97.2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/classpath/classpath-native-0.97.2/autotools.patch b/packages/classpath/classpath-native-0.97.2/autotools.patch
new file mode 100644 (file)
index 0000000..3df65cf
--- /dev/null
@@ -0,0 +1,26 @@
+Index: classpath-0.97.2/configure.ac
+===================================================================
+--- classpath-0.97.2.orig/configure.ac 2008-06-06 02:58:57.000000000 +0200
++++ classpath-0.97.2/configure.ac      2008-08-02 00:58:16.537364104 +0200
+@@ -41,6 +41,8 @@
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local/classpath)
++AC_CONFIG_MACRO_DIR([m4])
++
+ dnl -----------------------------------------------------------
+ dnl Enable collections.jar (disabled by default)
+ dnl -----------------------------------------------------------
+Index: classpath-0.97.2/Makefile.am
+===================================================================
+--- classpath-0.97.2.orig/Makefile.am  2008-06-01 20:47:05.000000000 +0200
++++ classpath-0.97.2/Makefile.am       2008-08-02 00:58:39.004023720 +0200
+@@ -5,7 +5,7 @@
+ DIST_SUBDIRS = lib doc external include native resource scripts tools examples
+ # Allow users to pass site-specific flags to autoreconf via an env var. 
+-ACLOCAL_AMFLAGS = -I m4 ${LOCAL_AUTORECONF_FLAGS}
++ACLOCAL_AMFLAGS = -I m4 --install ${LOCAL_AUTORECONF_FLAGS}
+ native: lib
index 3f18c5f..992a16e 100644 (file)
@@ -5,11 +5,18 @@ LICENSE = "Classpath"
 S = "${WORKDIR}/classpath-${PV}"
 
 SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
+         
 
 DEPENDS = "ecj-initial fastjar-native zip-native gettext-native"
 
 inherit autotools native
 
+
+do_configure_prepend () {
+
+       cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}
+}
+
 export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
 
 # Note: the --with-ecj options seems redundant but is
@@ -29,14 +36,7 @@ EXTRA_OECONF = "\
   --includedir=${STAGING_INCDIR}/classpath \
   --with-vm=java \
   "
-# hack to get config.rpath in, it comes from gettext
-do_configure_prepend () {
-
-        ${@['','cp ${STAGING_DATADIR}/automake-1.10/config.rpath ${S}'][bb.data.getVar('PREFERRED_VERSION_automake-native',d,1) == '1.10']}
-
-}
 
 do_stage() {
        oe_runmake install
 }
-
index a354b6b..2d7ebad 100644 (file)
@@ -1,6 +1,6 @@
 require classpath-native.inc
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI += "\
   file://gjar-prefix-patch.diff;patch=1;pnum=0 \
index c25b184..c9a2394 100644 (file)
@@ -10,5 +10,7 @@ SRC_URI += "\
   file://SimpleName.diff;patch=1;pnum=0 \
   file://javanet-local.patch;patch=1;pnum=0 \
   file://sun-security-getproperty_0.96.1.patch;patch=1;pnum=0 \
+  file://ecj_java_dir.patch;patch=1 \
+  file://autotools.patch;patch=1 \
   "
 
index cee0985..65bc465 100644 (file)
@@ -17,6 +17,7 @@ RPROVIDES_${PN}-common = "${PBN}-common"
 RPROVIDES_${PN}-gtk = "${PBN}-awt"
 
 SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
+         
 
 S = "${WORKDIR}/${PBN}-${PV}"
 
@@ -30,21 +31,19 @@ EXTRA_OECONF = "\
 
 inherit autotools
 
-# hack to get config.rpath in, it comes from gettext
 do_configure_prepend () {
 
-        ${@['','cp ${STAGING_DATADIR_NATIVE}/automake-1.10/config.rpath ${S}'][bb.data.getVar('PREFERRED_VERSION_automake-native',d,1) == '1.10']}
-
+        cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}
 }
        
 
 do_stage() {
        install -d ${STAGING_INCDIR}/classpath
        install -m 0644 include/jni* ${STAGING_INCDIR}/classpath
-  install -m 0644 include/jni_md.h ${STAGING_INCDIR}/classpath/
+       install -m 0644 include/jni_md.h ${STAGING_INCDIR}/classpath/
 
-  install -d ${STAGING_DATADIR}/classpath
-  install -m 0644 lib/glibj.zip ${STAGING_DATADIR}/classpath  
+       install -d ${STAGING_DATADIR}/classpath
+       install -m 0644 lib/glibj.zip ${STAGING_DATADIR}/classpath  
 }
 
 do_install() {
index 45ce04f..7e5ca45 100644 (file)
@@ -6,7 +6,7 @@ SRC_URI += "\
   file://javanet-local.patch;patch=1;pnum=0 \
   "
 
-PR = "r4"
+PR = "r5"
 
 DEPENDS += "gtk+ gconf libxtst"
 
index 6952cda..b4dd8b5 100644 (file)
@@ -6,7 +6,7 @@ SRC_URI += "\
   file://javanet-local.patch;patch=1;pnum=0 \
   "
 
-PR = "r6"
+PR = "r7"
 
 DEPENDS += "gtk+ gconf libxtst"
 
@@ -20,5 +20,3 @@ EXTRA_OECONF += "\
                 --enable-local-sockets \
                 --with-vm=java \
                "
-
-
index ef43374..1393e2c 100644 (file)
@@ -4,9 +4,11 @@ SRC_URI += "\
   file://netif_16.patch;patch=1;pnum=0 \
   file://SimpleName.diff;patch=1;pnum=0 \
   file://javanet-local.patch;patch=1;pnum=0 \
+  file://ecj_java_dir.patch;patch=1 \
+  file://autotools.patch;patch=1 \
   "
 
-PR = "r1"
+PR = "r2"
 
 DEPENDS += "gtk+ gconf libxtst"
 
diff --git a/packages/classpath/files/autotools.patch b/packages/classpath/files/autotools.patch
new file mode 100644 (file)
index 0000000..baae366
--- /dev/null
@@ -0,0 +1,37 @@
+Index: classpath-0.93/configure.ac
+===================================================================
+--- classpath-0.93.orig/configure.ac   2006-12-08 20:22:50.000000000 +0100
++++ classpath-0.93/configure.ac        2008-08-25 22:07:40.711946598 +0200
+@@ -41,6 +41,11 @@
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local/classpath)
++AC_CONFIG_MACRO_DIR([m4])
++
++
++AM_ICONV_LINK
++
+ dnl -----------------------------------------------------------
+ dnl Enable collections.jar (disabled by default)
+ dnl -----------------------------------------------------------
+@@ -312,6 +317,7 @@
+ dnl AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_CPP
++AM_PROG_CC_C_O
+ # Handle -Werror default case.
+ if test "$ENABLE_WERROR" = default; then
+Index: classpath-0.93/Makefile.am
+===================================================================
+--- classpath-0.93.orig/Makefile.am    2006-02-08 08:35:30.000000000 +0100
++++ classpath-0.93/Makefile.am 2008-08-24 21:45:42.405241264 +0200
+@@ -4,7 +4,7 @@
+ SUBDIRS = lib doc external include native resource scripts tools $(EXAMPLESDIR)
+ DIST_SUBDIRS = lib doc external include native resource scripts tools examples
+-ACLOCAL_AMFLAGS = -I m4
++ACLOCAL_AMFLAGS = -I m4 --install
+ native: lib
diff --git a/packages/classpath/files/ecj_java_dir.patch b/packages/classpath/files/ecj_java_dir.patch
new file mode 100644 (file)
index 0000000..e310567
--- /dev/null
@@ -0,0 +1,34 @@
+Index: classpath-0.97.2/lib/gen-classlist.sh.in
+===================================================================
+--- classpath-0.97.2.orig/lib/gen-classlist.sh.in      2008-06-02 03:37:29.000000000 +0200
++++ classpath-0.97.2/lib/gen-classlist.sh.in   2008-08-01 00:00:58.055208770 +0200
+@@ -148,4 +148,7 @@
+   done
+ fi
++# hack for javac that uses -d and do not make the directories
++awk -F " " '{print $1}' classes.1 | uniq | awk -F " " '{system("mkdir -p " $0)}'
++
+ exit 0
+Index: classpath-0.97.2/tools/Makefile.am
+===================================================================
+--- classpath-0.97.2.orig/tools/Makefile.am    2008-06-02 04:01:47.000000000 +0200
++++ classpath-0.97.2/tools/Makefile.am 2008-08-01 00:11:18.531985989 +0200
+@@ -180,6 +180,8 @@
+       mkdir classes asm
+ ## Compile ASM separately as it is latin-1 encoded.
+       find $(srcdir)/external/asm -name '*.java' -print > asm.lst
++      awk -F "/" '{OFS=FS;gsub("/"$$2"/"$$3,"",$$0);gsub("/"$$NF,"",$$0); print $$0}' asm.lst | \
++         sort | uniq | awk -F " " '{system("mkdir -p asm/" $$0)}'
+       AC=`echo $(JCOMPILER) | sed -e 's/UTF-8/ISO-8859-1/g'`; \
+         $$AC -g -d asm @asm.lst
+       find $(srcdir)/gnu/classpath/tools \
+@@ -189,6 +191,8 @@
+            $(srcdir)/com/sun/tools/javah \
+            $(srcdir)/sun/rmi/rmic \
+            -name '*.java' -print > classes.lst
++      awk -F "/" '{OFS=FS;gsub("/"$$NF,"",$$0); print $$0}' classes.lst | \
++           sort | uniq | awk -F " " '{system("mkdir -p classes/" $$0)}'
+       $(JCOMPILER) -g -d classes @classes.lst
+       cat classes.lst asm.lst > all-classes.lst
+ ## Copy over tools resource files.