python-oeventd: add bb-file and update fso-image
authorJan Lübbe <jluebbe@debian.org>
Mon, 26 May 2008 21:52:28 +0000 (21:52 +0000)
committerJan Lübbe <jluebbe@debian.org>
Mon, 26 May 2008 21:52:28 +0000 (21:52 +0000)
conf/distro/include/fso-autorev.inc
conf/distro/include/sane-srcrevs.inc
packages/freesmartphone/python-oeventd/.mtn2git_empty [new file with mode: 0644]
packages/freesmartphone/python-oeventd/oeventd [new file with mode: 0644]
packages/freesmartphone/python-oeventd_git.bb [new file with mode: 0644]
packages/images/fso-image.bb

index df53515..65a4543 100644 (file)
@@ -4,6 +4,7 @@ SRCREV_pn-mickeyterm = "${AUTOREV}"
 SRCREV_pn-pyneod = "${AUTOREV}"
 SRCREV_pn-pynoeg = "${AUTOREV}"
 SRCREV_pn-python-odeviced = "${AUTOREV}"
+SRCREV_pn-python-oeventd = "${AUTOREV}"
 SRCREV_pn-python-ophoned = "${AUTOREV}"
 SRCREV_pn-python-ousaged = "${AUTOREV}"
 SRCREV_pn-python-pytrc = "${AUTOREV}"
index 2e6a2bb..d255844 100644 (file)
@@ -160,6 +160,7 @@ SRCREV_pn-packagekit ?= "74a3b7e3f3bc8627c23349e0b0d8429fd5f53fc6"
 SRCREV_pn-psplash ?= "249"
 SRCREV_pn-pty-forward-native ?= "4214"
 SRCREV_pn-python-odeviced ?= "2f02576532b52732251b3c530a09e4c08685a911"
+SRCREV_pn-python-oeventd ?= "d9646ee640fe6eabd023b82a7a0b8ed529cf07b7"
 SRCREV_pn-python-ophoned ?= "8bb89a912163c8a846be7a14b2a6e2f832f91bd6"
 SRCREV_pn-python-ousaged ?= "c7f83c3f696b6e72f3cab244af4e88dc4851018e"
 SRCREV_pn-pygsm ?= "976477f6b403f422b4ea730f71ebf409f6671141"
diff --git a/packages/freesmartphone/python-oeventd/.mtn2git_empty b/packages/freesmartphone/python-oeventd/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/freesmartphone/python-oeventd/oeventd b/packages/freesmartphone/python-oeventd/oeventd
new file mode 100644 (file)
index 0000000..8ed467b
--- /dev/null
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# odeviced  This shell script starts and stops the open event daemon.
+#
+# chkconfig: 345 90 20
+# description: py-oeventd is the open evend daemon
+# processname: python
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+NAME=oeventd
+
+[ -f /etc/default/rcS ] && . /etc/default/rcS
+
+case "$1" in
+    start)
+        echo -n "Starting open event daemon: "
+        start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/oeventd
+        if [ $? = 0 ]; then
+            echo "(ok)"
+        else
+            echo "(failed)"
+        fi
+        ;;
+    stop)
+        echo -n "Stopping open event daemon: "
+        start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
+        rm -f /var/run/${NAME}.pid
+        echo "(done)"
+        ;;
+    restart|force-reload)
+        $0 stop
+        $0 start
+        ;;
+    *)
+        echo "Usage: /etc/init.d/oeventd {start|stop|restart|force-reload}"
+        exit 1
+        ;;
+esac
+
+exit 0
diff --git a/packages/freesmartphone/python-oeventd_git.bb b/packages/freesmartphone/python-oeventd_git.bb
new file mode 100644 (file)
index 0000000..2f77905
--- /dev/null
@@ -0,0 +1,34 @@
+DESCRIPTION = "The Open Event Daemon Prototype in Python"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenEventDaemon"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+DEPENDS = "python-cython-native python-pyrex-native"
+LICENSE = "GPLv2"
+PV = "0.0.0+gitr${SRCREV}"
+PR = "r0"
+
+inherit distutils update-rc.d
+
+INITSCRIPT_NAME = "oeventd"
+INITSCRIPT_PARAMS = "defaults 20"
+
+SRC_URI = "\
+  ${FREESMARTPHONE_GIT}/eventd.git;protocol=git;branch=master \
+  file://oeventd \
+"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/init.d/
+       install -m 0755 ${WORKDIR}/oeventd ${D}${sysconfdir}/init.d/
+       install -d ${D}${sysconfdir}/dbus-1/system.d/
+       mv -f ${D}${datadir}/etc/dbus-1/system.d/oeventd.conf ${D}${sysconfdir}/dbus-1/system.d/
+}
+
+RDEPENDS_${PN} += "\
+  python-dbus \
+  python-pygobject \
+  python-syslog \
+"
+
+FILES_${PN} += "${sysconfdir}"
index 72cbfd7..1d90b5c 100644 (file)
@@ -24,6 +24,7 @@ MICKEY_INSTALL = "\
 ZHONE_INSTALL = "\
   gsm0710muxd \
   python-odeviced \
+  python-oeventd \
   python-ophoned \
   python-ousaged \
   zhone \
@@ -50,6 +51,10 @@ IMAGE_INSTALL = "\
   \
   python-codecs \
   \
+  openmoko-alsa-scenarios \
+  openmoko-sound-system2 \
+  openmoko-sound-theme-standard2 \
+  \
   ${ADD_INSTALL} \
   ${MICKEY_INSTALL} \
   ${ZHONE_INSTALL} \