console-base-image,console-image,gnuradio-image: readd psplash-zap
authorAndrea Adami <andrea.adami@gmail.com>
Thu, 23 Apr 2009 21:46:21 +0000 (23:46 +0200)
committerAndrea Adami <andrea.adami@gmail.com>
Thu, 23 Apr 2009 21:49:33 +0000 (23:49 +0200)
 - for distros without psplash keep the old behaviour and check 'screen'

recipes/images/console-base-image.bb
recipes/images/console-image.bb
recipes/images/gnuradio-image.bb

index 93391c6..d25a4fc 100644 (file)
@@ -4,18 +4,20 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
 
 ANGSTROM_EXTRA_INSTALL ?= ""
 
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
 
 DEPENDS = "task-base \
            ${SPLASH} \
+           ${ZZAPSPLASH} \
           "
 
 IMAGE_INSTALL = "task-base \
            ${ANGSTROM_EXTRA_INSTALL} \
            ${SPLASH} \
-          "
+           ${ZZAPSPLASH} \
+           "
 
 IMAGE_LINGUAS = ""
 
 inherit image
-
index e30793b..9707881 100644 (file)
@@ -4,19 +4,21 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
 
 ANGSTROM_EXTRA_INSTALL ?= ""
 
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
 
 DEPENDS = "task-base-extended \
            ${SPLASH} \
+           ${ZZAPSPLASH} \
           "
 
 IMAGE_INSTALL = "task-base-extended \
            ${ANGSTROM_EXTRA_INSTALL} \
            ${SPLASH} \
-          "
+           ${ZZAPSPLASH} \
+           "
 
 export IMAGE_BASENAME = "console-image"
 IMAGE_LINGUAS = ""
 
 inherit image
-
index ce4f499..53e79b8 100644 (file)
@@ -4,25 +4,27 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
 
 IMAGE_EXTRA_INSTALL ?= ""
 
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
 
 DEPENDS = "task-base-extended \
            ${SPLASH} \
+           ${ZZAPSPLASH} \
           "
 
 IMAGE_INSTALL = "task-base-extended \
            ${IMAGE_EXTRA_INSTALL} \
            ${SPLASH} \
+           ${ZZAPSPLASH} \
             oprofile \
             screen \
             ntp ntp-bin \
             make \
             nfs-utils-client \
             gnuradio gnuradio-examples \
-          "
+           "
 
 export IMAGE_BASENAME = "gnuradio-image"
 IMAGE_LINGUAS = ""
 
 inherit image
-