linux-openmoko_2.6.24.bb : turn off SRCREV_FORMAT until I get time to
authorGraeme Gregory <dp@xora.org.uk>
Fri, 21 Mar 2008 03:19:33 +0000 (03:19 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Fri, 21 Mar 2008 03:19:33 +0000 (03:19 +0000)
implement both way transfer of SRCREV_FORMAT to/from svn fetchers.

conf/distro/include/sane-srcrevs.inc
packages/linux/linux-openmoko_2.6.24.bb

index 21c1d3c..cb960d5 100644 (file)
@@ -57,7 +57,7 @@ SRCREV_pn-lightmediascanner ?= "68"
 SRCREV_pn-linux-bfin ?= "3758"
 SRCREV_pn-linux-hackndev-2.6 ?= "1308"
 SRCREV_pn-linux-ixp4xx ?= "1039"
-SRCREV_pn-linux-openmoko ?= "4194-r4165"
+SRCREV_pn-linux-openmoko ?= "4194"
 SRCREV_pn-llvm-gcc4 ?= "374"
 SRCREV_pn-llvm-gcc4-cross ?= "374"
 SRCREV_pn-maemo-mapper ?= "118"
index b316f4a..8c1f28d 100644 (file)
@@ -8,8 +8,12 @@ KERNEL_RELEASE = "2.6.24"
 # need to synchronize with LOCALVERSION, if set
 KERNEL_VERSION = "${KERNEL_RELEASE}"
 
-PV = "${VANILLA_VERSION}+svnr${SRCREV}"
-PR = "r3"
+# re-enabled this when feature is fully implemented in OE
+#SRCREV_FORMAT = "patches-rconfig"
+CONFIG_REV = "4165"
+
+PV = "${VANILLA_VERSION}+svnr${SRCREV}-r${CONFIG_REV}"
+PR = "r4"
 
 KERNEL_IMAGETYPE = "uImage"
 UBOOT_ENTRYPOINT = "30008000"
@@ -17,11 +21,10 @@ UBOOT_ENTRYPOINT = "30008000"
 ##############################################################
 # source and patches
 #
-SRCREV_FORMAT = "patches-rconfig"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
            svn://svn.openmoko.org/branches/src/target/kernel/2.6.24.x;module=patches;proto=http;name=patches \
-           svn://svn.openmoko.org/branches/src/target/kernel/2.6.24.x;module=config;proto=http;name=config "
+           svn://svn.openmoko.org/branches/src/target/kernel/2.6.24.x;module=config;proto=http;rev=${CONFIG_REV};name=config "
 
 S = "${WORKDIR}/linux-${VANILLA_VERSION}"