hildon-control-panel: added 2.0.1
authorMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 3 Mar 2008 16:11:04 +0000 (16:11 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 3 Mar 2008 16:11:04 +0000 (16:11 +0000)
packages/maemo4/hildon-control-panel_2.0.1.bb [new file with mode: 0644]

diff --git a/packages/maemo4/hildon-control-panel_2.0.1.bb b/packages/maemo4/hildon-control-panel_2.0.1.bb
new file mode 100644 (file)
index 0000000..d7dd6c3
--- /dev/null
@@ -0,0 +1,20 @@
+LICENSE    = "GPL"
+
+DEPENDS = "libosso libhildon gnome-vfs libhildonhelp"
+
+SRC_URI = "http://repository.maemo.org/pool/os2008/free/source/h/hildon-control-panel/hildon-control-panel_2.0.1-1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${datadir}/applications"
+
+do_stage() {
+       autotools_stage_all
+}
+
+# pkg-config file will get broken after pkgconfig.bbclass work
+# 
+# This code will fix it
+#
+#      sed -i -e 's:${STAGING_LIBDIR}/hildon:${libdir}/hildon:g' -e 's:${STAGING_DATADIR}/applications/hildon:${datadir}/applications/hildon:g' ${PKG_CONFIG_DIR}/hildon-control-panel.pc
+#