udev 124: fix the absolute soname link in libvolume for SDK
authorDenys Dmytriyenko <denis@denix.org>
Mon, 13 Apr 2009 22:25:04 +0000 (18:25 -0400)
committerDenys Dmytriyenko <denis@denix.org>
Tue, 14 Apr 2009 19:20:49 +0000 (15:20 -0400)
recipes/udev/udev-124/libvolume-id-soname.patch [new file with mode: 0644]
recipes/udev/udev_124.bb

diff --git a/recipes/udev/udev-124/libvolume-id-soname.patch b/recipes/udev/udev-124/libvolume-id-soname.patch
new file mode 100644 (file)
index 0000000..56365a4
--- /dev/null
@@ -0,0 +1,12 @@
+diff -uNr udev-124-orig/extras/volume_id/lib/Makefile udev-124/extras/volume_id/lib/Makefile
+--- udev-124-orig/extras/volume_id/lib/Makefile        2008-06-12 01:24:30.000000000 -0400
++++ udev-124/extras/volume_id/lib/Makefile     2009-01-14 23:32:42.000000000 -0500
+@@ -113,7 +113,7 @@
+ ifeq ($(libdir),$(usrlibdir))
+       ln -sf $(SHLIB) $(DESTDIR)$(usrlibdir)/libvolume_id.so
+ else
+-      ln -sf $(libdir)/$(SHLIB) $(DESTDIR)$(usrlibdir)/libvolume_id.so
++      ln -sf ../..$(libdir)/$(SHLIB) $(DESTDIR)$(usrlibdir)/libvolume_id.so
+ endif
+       $(INSTALL) -d $(DESTDIR)$(usrlibdir)/pkgconfig
+       $(INSTALL_DATA) libvolume_id.pc $(DESTDIR)$(usrlibdir)/pkgconfig/libvolume_id.pc
index 76edb2f..37dc3a7 100644 (file)
@@ -2,13 +2,14 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 /dev/, handles hotplug events and loads drivers at boot time. It replaces \
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES_${PN} = "hotplug"
-PR = "r14"
+PR = "r15"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://noasmlinkage.patch;patch=1 \
           file://flags.patch;patch=1 \
           file://vol_id_ld.patch;patch=1 \
           file://udevtrigger_add_devname_filtering.patch;patch=1 \
+          file://libvolume-id-soname.patch;patch=1 \
           file://mount.blacklist \
           file://run.rules \
           "