cpusage: Add 0.1 and 0.2 (from Stelios Koroneos #775)
authorRichard Purdie <rpurdie@rpsys.net>
Tue, 4 Apr 2006 21:41:30 +0000 (21:41 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 4 Apr 2006 21:41:30 +0000 (21:41 +0000)
packages/cpusage/.mtn2git_empty [new file with mode: 0644]
packages/cpusage/cpusage-0.1/.mtn2git_empty [new file with mode: 0644]
packages/cpusage/cpusage-0.1/cpusage.patch [new file with mode: 0644]
packages/cpusage/cpusage_0.1.bb [new file with mode: 0644]
packages/cpusage/cpusage_0.2.bb [new file with mode: 0644]

diff --git a/packages/cpusage/.mtn2git_empty b/packages/cpusage/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/cpusage/cpusage-0.1/.mtn2git_empty b/packages/cpusage/cpusage-0.1/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/cpusage/cpusage-0.1/cpusage.patch b/packages/cpusage/cpusage-0.1/cpusage.patch
new file mode 100644 (file)
index 0000000..091c7a9
--- /dev/null
@@ -0,0 +1,63 @@
+--- /orig-cpusage.c    2005-08-16 15:37:25.000000000 +0300
++++ /cpusage.c 2006-03-17 22:27:09.000000000 +0200
+@@ -168,6 +168,7 @@
+ int main(int argc, char** argv) {
+     int i,c,limit;
++    int single;  /* run just one's and exit */
+     int avg; /* is avg measurement allready running */ 
+     int avg_run; /* did we allready had an avg measurement */
+     static long cp_time1[CPUSTATES];
+@@ -184,15 +185,21 @@
+     long total;
+     limit = LIMIT;
+     output = 0; /* human readable */
++    single = 1; /*run continuesly */
+     /* reading commandline options */
+     while (1) {
+-      c = getopt(argc, argv, "aohl:");
++      c = getopt(argc, argv, "saohl:");
+       
+-      if (c == -1)
++      if (c == -1){
+           break;
++        }
+       switch(c){
++        case 's':
++        /*run once and exit */
++           single = 0;             
++           break;
+       /* use avg from begin to end -> same as "-l 100" */
+       case 'a':
+           limit = 100; 
+@@ -278,6 +285,10 @@
+       print_perc(cpu_perc, ""); 
++        if (!single ) {
++          breakloop=1;
++        }
++
+       if (breakloop) {
+           if (avg) {
+               avg = 0;
+@@ -292,7 +303,8 @@
+     if (sigaction(SIGINT, &sigold, &signew) < 0 ){
+       fprintf(stderr, "Could not restore signal handler -> exiting");
+     }
+-    
++
++   if (single != 0) {    
+     printf("---Summary----\n");
+     
+     print_perc(cpu_min, "Min");
+@@ -301,6 +313,7 @@
+     perc(CPUSTATES, cp_avg_start, cp_avg_stop, cp_diff); 
+     print_perc(cpu_perc, "Avg");
++  }
+     
+     return 0;
+ }
diff --git a/packages/cpusage/cpusage_0.1.bb b/packages/cpusage/cpusage_0.1.bb
new file mode 100644 (file)
index 0000000..d90c630
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "This tool read out the tics counter of the operating system and \
+calculates the Percentages spend in each CPU_STATE."
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz \
+           file://cpusage.patch;patch=1"
+
+S = "${WORKDIR}/cpusage-${PV}"
+
+FILES_${PN} = "/sbin/cpusage"
+
+CFLAGS_append =" -D_BSD_SOURCE=1"
+CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
+
+do_compile() {
+       ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
+}
+
+do_install() {
+       install -d ${D}${base_sbindir}
+       install -m 0755 cpusage ${D}${base_sbindir}/cpusage
+}
diff --git a/packages/cpusage/cpusage_0.2.bb b/packages/cpusage/cpusage_0.2.bb
new file mode 100644 (file)
index 0000000..7d4df4e
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "This tool read out the tics counter of the operating system and \
+calculates the Percentages spend in each CPU_STATE."
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz"
+
+S = "${WORKDIR}/cpusage-${PV}"
+
+FILES_${PN} = "/sbin/cpusage"
+
+CFLAGS_append =" -D_BSD_SOURCE=1"
+CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
+
+
+do_compile() {
+       ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
+}
+
+do_install() {
+       install -d ${D}${base_sbindir}
+       install -m 0755 cpusage ${D}${base_sbindir}/cpusage
+}