alsa-lib: fix "error: field 'tstamp' has incomplete type" when including alsa headers...
authorMichael Lauer <mickey@vanille-media.de>
Thu, 18 Jan 2007 00:27:21 +0000 (00:27 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Thu, 18 Jan 2007 00:27:21 +0000 (00:27 +0000)
packages/alsa/alsa-lib/.mtn2git_empty [new file with mode: 0644]
packages/alsa/alsa-lib/fix-tstamp-declaration.patch [new file with mode: 0644]
packages/alsa/alsa-lib_1.0.13.bb

diff --git a/packages/alsa/alsa-lib/.mtn2git_empty b/packages/alsa/alsa-lib/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/alsa/alsa-lib/fix-tstamp-declaration.patch b/packages/alsa/alsa-lib/fix-tstamp-declaration.patch
new file mode 100644 (file)
index 0000000..59b3b6d
--- /dev/null
@@ -0,0 +1,13 @@
+Index: alsa-lib-1.0.13/include/global.h
+===================================================================
+--- alsa-lib-1.0.13.orig/include/global.h
++++ alsa-lib-1.0.13/include/global.h
+@@ -29,6 +29,8 @@
+ #define __ALSA_GLOBAL_H_
+ /* for timeval and timespec */
++#define __need_timeval
++#define __need_timespec
+ #include <time.h>
+ #ifdef __cplusplus
index 987a590..8b6b7af 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Alsa sound library"
 HOMEPAGE = "http://www.alsa-project.org"
 SECTION = "libs/multimedia"
 LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
 
 # configure.in sets -D__arm__ on the command line for any arm system
 # (not just those with the ARM instruction set), this should be removed,
@@ -10,7 +10,8 @@ PR = "r0"
 #FIXME: remove the following
 ARM_INSTRUCTION_SET = "arm"
 
-SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
+           file://fix-tstamp-declaration.patch;patch=1"
 
 inherit autotools pkgconfig