moblin: add recipes from poky 'meta-moblin' overlay
authorKoen Kooi <koen@openembedded.org>
Sun, 31 May 2009 14:51:24 +0000 (16:51 +0200)
committerKoen Kooi <koen@openembedded.org>
Sun, 31 May 2009 14:51:24 +0000 (16:51 +0200)
* the juicy parts depend on clutter and clutter-gst

recipes/moblin/bickley_git.bb [new file with mode: 0644]
recipes/moblin/json-glib_0.6.2.bb [new file with mode: 0644]
recipes/moblin/json-glib_git.bb [new file with mode: 0644]
recipes/moblin/libccss_git.bb [new file with mode: 0644]
recipes/moblin/librest_git.bb [new file with mode: 0644]
recipes/moblin/moblin-menus/configurefix.patch [new file with mode: 0644]
recipes/moblin/moblin-menus_git.bb [new file with mode: 0644]
recipes/moblin/mojito_git.bb [new file with mode: 0644]
recipes/moblin/twitter-glib_git.bb [new file with mode: 0644]

diff --git a/recipes/moblin/bickley_git.bb b/recipes/moblin/bickley_git.bb
new file mode 100644 (file)
index 0000000..26bf40d
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "A meta data manager API and framework (including Media)"
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+PV = "0.0"
+PR_append = "+git${SRCREV}"
+PR = "r3"
+
+DEPENDS = "redland gtk+ dbus-glib clutter-gst libexif taglib gupnp gupnp-av samba"
+RDEPENDS = "xdg-user-dirs"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} =+ "${datadir}/dbus-1/services/"
+
+inherit autotools_stage
+
+do_compile_prepend() {
+       sed -i -e '/#  warn /d' src/bkl-investigator.c
+}
+
diff --git a/recipes/moblin/json-glib_0.6.2.bb b/recipes/moblin/json-glib_0.6.2.bb
new file mode 100644 (file)
index 0000000..822ddad
--- /dev/null
@@ -0,0 +1,7 @@
+
+SRC_URI = "http://folks.o-hand.com/~ebassi/sources/json-glib-0.6.2.tar.gz"
+PR = "r0"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools_stage
diff --git a/recipes/moblin/json-glib_git.bb b/recipes/moblin/json-glib_git.bb
new file mode 100644 (file)
index 0000000..0522df1
--- /dev/null
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://live.gnome.org/JsonGlib"
+SRC_URI = "git://github.com/ebassi/${PN}.git;protocol=git"
+PV = "0.6.2+git${SRCREV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools_stage
+
+acpaths = "-I ${S}/build/autotools "
+
+do_configure_prepend () {
+       touch ${S}/gtk-doc.make
+}
\ No newline at end of file
diff --git a/recipes/moblin/libccss_git.bb b/recipes/moblin/libccss_git.bb
new file mode 100644 (file)
index 0000000..e622d9f
--- /dev/null
@@ -0,0 +1,14 @@
+SRC_URI = "git://anongit.freedesktop.org/git/ccss.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r0"
+
+DEPENDS = "glib-2.0 cairo librsvg libsoup-2.4"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+       echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+       echo "CLEANFILES=" >> ${S}/gtk-doc.make
+}
diff --git a/recipes/moblin/librest_git.bb b/recipes/moblin/librest_git.bb
new file mode 100644 (file)
index 0000000..ec2d676
--- /dev/null
@@ -0,0 +1,14 @@
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r0"
+
+DEPENDS = "libsoup-2.4"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+       echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+}
diff --git a/recipes/moblin/moblin-menus/configurefix.patch b/recipes/moblin/moblin-menus/configurefix.patch
new file mode 100644 (file)
index 0000000..288746a
--- /dev/null
@@ -0,0 +1,13 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in      2009-01-17 18:57:24.000000000 +0000
++++ git/configure.in   2009-01-17 18:57:29.000000000 +0000
+@@ -11,8 +11,6 @@
+ AM_MAINTAINER_MODE
+-AM_DISABLE_STATIC
+-      
+ changequote(,)dnl
+ if test "x$GCC" = "xyes"; then
+   case " $CFLAGS " in
diff --git a/recipes/moblin/moblin-menus_git.bb b/recipes/moblin/moblin-menus_git.bb
new file mode 100644 (file)
index 0000000..ae60573
--- /dev/null
@@ -0,0 +1,11 @@
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
+           file://configurefix.patch;patch=1"
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}/desktop-directories/*"
+
+inherit autotools_stage
diff --git a/recipes/moblin/mojito_git.bb b/recipes/moblin/mojito_git.bb
new file mode 100644 (file)
index 0000000..b29aaed
--- /dev/null
@@ -0,0 +1,29 @@
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r2"
+
+DEPENDS = "libsoup-2.4 gconf-dbus librest glib-2.0 twitter-glib sqlite3 gnome-keyring"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+FILES_${PN}-dbg += "${libdir}/mojito/sources/.debug/* ${libdir}/mojito/services/.debug/"
+
+PARALLEL_MAKE = ""
+
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+    exit 1
+fi
+    
+. ${sysconfdir}/init.d/functions
+    
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string -s /apps/mojito/sources/flickr/user 34402200@N07
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.default  --direct --type string -s /apps/mojito/sources/twitter/user ross@linux.intel.com
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string -s /apps/mojito/sources/twitter/password password 
+
+}
diff --git a/recipes/moblin/twitter-glib_git.bb b/recipes/moblin/twitter-glib_git.bb
new file mode 100644 (file)
index 0000000..791cace
--- /dev/null
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://live.gnome.org/TwitterGlib"
+SRC_URI = "git://github.com/ebassi/${PN}.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r0"
+
+DEPENDS = "glib-2.0 gtk+ json-glib"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--disable-shave --disable-introspection"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+        echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+}
\ No newline at end of file